Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 136028 - disable oss support
disable oss support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 136119 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 19:51 EDT by Féliciano Matias
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 16:17:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to gstreamer-plugins.spec (1.56 KB, patch)
2004-10-16 19:59 EDT, Féliciano Matias
no flags Details | Diff
Fix to build arts plugin without oss plugin (2.21 KB, patch)
2004-10-16 20:01 EDT, Féliciano Matias
no flags Details | Diff

  None (edit)
Description Féliciano Matias 2004-10-16 19:51:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
OSS is deprecated and FC3 does not provide OSS drivers (only OSS
emulation with alsa for "old" programs). So, perhaps it's time to
disable OSS support in gstreamer-plugins.

This will avoid to have mixer listed twice is gnome-volume-control and
/usr/libexec/mixer_applet2 (gnome-panel).

Version-Release number of selected component (if applicable):
gstreamer-plugins-0.8.5-1

Additional info:

gnome-volume-control with oss support (FC3) :
http://feliciano.matias.free.fr/gnome-volume-control/g-v-c_old.png
without oss support
http://feliciano.matias.free.fr/gnome-volume-control/g-v-c_new.png

window preference of mixer applet with oss support :
http://feliciano.matias.free.fr/gnome-volume-control/sound-applet_old.png
without oss support :
http://feliciano.matias.free.fr/gnome-volume-control/sound-applet_new.png
Comment 1 Féliciano Matias 2004-10-16 19:59:08 EDT
Created attachment 105332 [details]
Patch to gstreamer-plugins.spec

The patch disable oss support and add missing libmusicbrainz-devel dependency.
Comment 2 Féliciano Matias 2004-10-16 20:01:49 EDT
Created attachment 105333 [details]
Fix to build arts plugin without oss plugin

Perhaps it's ugly. I don't know how autoconf works.
Comment 3 Colin Walters 2004-10-18 16:17:28 EDT
Instead of this, I simplay disabled display of OSS mixers in gst-mixer.  Fixed
in 2.8.0-2.
Comment 4 Colin Walters 2004-10-18 16:39:26 EDT
*** Bug 136119 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.