Bug 136038 - new autofs v4 in update3 breaks file map support
new autofs v4 in update3 breaks file map support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 21:59 EDT by Steven Roberts
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 4.1.3-130
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-27 12:36:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Roberts 2004-10-16 21:59:17 EDT
Description of problem:
With update3, autofs was upgraded to version 4.1.3-12 from version
3.1.7-41.  with that update support for file based maps when the map
name in auto.master is a plain name (with an assumed prefix of /etc/)
is broken.

in particular in /etc/rc.d/init.d/autofs, getmounts function, these
lines were dropped:
  elif [ -f "/etc/$map" ]; then
      maptype=file
      map=`echo /etc/$map | sed 's^//^/^g'`

I was not expected breakages in compatibility like this within a given
major RHEL release.

with these lines missing, the map is assumed to be YP (falls through
to the bottom of the loop).  The automount entry in nsswitch.conf is:
automount:  files

Also, I am not sure if I can change the map name in auto.master as
some RH versions I think didn't support an absolute pathname as a map
name.  And the auto.master file is synchronized with a global network
copy.

Version-Release number of selected component (if applicable):
4.1.3-12

How reproducible:
always

Steps to Reproduce:
1. have a map in auto.master with a simple name (for example 'auto.home').
2. start up autofs
  
Actual results:
no map is loaded for auto.home and thus home directories don't get mounted

Expected results:
/etc/auto.home would get loaded and /home would get mounted by autofs
Comment 1 Steven Roberts 2004-10-19 15:57:17 EDT
Since I had to get the new boxes up, I went through the scripts for
rh6.2,rh7.3,rhel as2.1 (the versions we principally run at the moment
-- we also have rhel es2.1 and as2.1 for ia64 but I am figuring they
have the same scripts as rhel as2.1).  They do support an absolute
path for the map name.  tested and it works.

So I converetd the global config files to this.  so I have a work
around for me.

And adding those lines may cuase issues to people who use YP/NIS.  The
change though probably would be good to note in the RELNOTES when it
discusses the autofs version upgrade.
Comment 2 Chris Feist 2004-10-20 17:05:51 EDT
This bug has been fixed and will be include in RHEL 3.0 U5.

Note You need to log in before you can comment on or make changes to this bug.