Bug 136043 - Mozilla's file picker shows incorrect directories
Mozilla's file picker shows incorrect directories
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeui (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-16 23:49 EDT by Mike
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 11:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot of Mozilla File Picker showing incorrect contents (94.54 KB, image/png)
2004-10-16 23:52 EDT, Mike
no flags Details

  None (edit)
Description Mike 2004-10-16 23:49:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041012

Description of problem:
The file picker shows the incorrect directories.  When I select "/" in
the left hand side of the file picker it displays the contents of
/media/idedisk4 in the right hand pane. (See attached screenshot). 
When I select /home in the left hand pane it displays the contents of
/media/idedisk3 in the right hand pane.

Here's my /etc/fstab:
=====================
# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/1                /                       ext3    defaults     
  1 1
LABEL=/boot             /boot                   ext3    defaults     
  1 2
none                    /dev/pts                devpts  gid=5,mode=620
 0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
none                    /proc                   proc    defaults     
  0 0
none                    /sys                    sysfs   defaults     
  0 0
/dev/hda7               swap                    swap    defaults     
  0 0
/dev/hda10              swap                    swap    defaults     
  0 0
/dev/hda8               /media/idedisk          ext3   
exec,pamconsole,noauto,managed 0 0
/dev/hda6               /media/idedisk1         ext3   
exec,pamconsole,noauto,managed 0 0
/dev/hda5               /media/idedisk2         ext3   
exec,pamconsole,noauto,managed 0 0
/dev/hda3               /media/idedisk3         ext3   
exec,pamconsole,noauto,managed 0 0
/dev/hda2               /media/idedisk4         ext3   
exec,pamconsole,noauto,managed 0 0
/dev/scd0               /media/cdrecorder       iso9660,udf
exec,pamconsole,noauto,ro,managed 0 0
=========================


and here is my /etc/mtab:
=========================
# cat /etc/mtab
/dev/hda9 / ext3 rw 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /dev/pts devpts rw,gid=5,mode=620 0 0
usbfs /proc/bus/usb usbfs rw 0 0
/dev/hda1 /boot ext3 rw 0 0
none /dev/shm tmpfs rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/hda2 /media/idedisk4 ext3 rw,noexec,nosuid,nodev 0 0
/dev/hda3 /media/idedisk3 ext3 rw,noexec,nosuid,nodev 0 0
/dev/hda5 /media/idedisk2 ext3 rw,noexec,nosuid,nodev 0 0
/dev/hda6 /media/idedisk1 ext3 rw,noexec,nosuid,nodev 0 0
/dev/hda8 /media/idedisk ext3 rw,noexec,nosuid,nodev 0 0



Version-Release number of selected component (if applicable):
mozilla-1.7.3-13

How reproducible:
Always

Steps to Reproduce:
1. Select Mozilla's File Pull-down menu
2. Select Mozilla's Open File menu
3. Select the "/" directory in the left hand pane.
    

Actual Results:  Incorrect directory contents are displayed:

"/media/idedisk4"

Expected Results:  Correct directory contents
"/"

Additional info:
Comment 1 Mike 2004-10-16 23:52:56 EDT
Created attachment 105340 [details]
Screen Shot of Mozilla File Picker showing incorrect contents

Note the "media" and "idedisk4" notations at the top of the right hand pane and
the "/" clearly selected in the left.
Comment 2 Christopher Aillon 2005-03-31 05:48:32 EST
The file picker is actually a gtk2 component.  Moving bug.
Comment 3 Matthias Clasen 2005-08-22 09:51:06 EDT
But the file chooser is getting its information from the gnome-vfs backend.
Moving bug.
Comment 4 Ray Strode [halfline] 2007-03-28 12:42:53 EDT
Hi Mike,

Are you still seeing the problem, today?

Does this happen in things like gedit, too?  or just Mozilla/Seamonkey/Firefox?

what is the output of 

gconftool-2 --get /desktop/gnome/interface/file_chooser_backend

If you do

gconftool-2 --set /desktop/gnome/interface/file_chooser_backend --type string gtk+

does the problem go away?
Comment 5 Ray Strode [halfline] 2007-08-14 11:55:18 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to CANTFIX, however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thank you in advance.

(this message is mass message)

Note You need to log in before you can comment on or make changes to this bug.