Bug 136056 - rhn-applet-gui warning on startup
rhn-applet-gui warning on startup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-17 04:59 EDT by Nigel Horne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 22:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Horne 2004-10-17 04:59:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.3)
Gecko/20040922

Description of problem:
The following warning appears when starting rhn-applet-gui:

 /usr/share/rhn/rhn_applet/rhn_applet.py:362: DeprecationWarning:
integer argument expected, got float
  self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 *
ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)

Version-Release number of selected component (if applicable):
rhn-applet-2.1.7-1.1

How reproducible:
Always

Steps to Reproduce:
1. Start KDE
2. Start kterm
3. Run rhn-applet-gui&
    

Actual Results:   /usr/share/rhn/rhn_applet/rhn_applet.py:362:
DeprecationWarning: integer argument expected, got float
  self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 *
ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)

Expected Results:  No output

Additional info:
Comment 1 Adrian Likins 2004-10-19 15:53:42 EDT
fixed in 2.1.16
Comment 2 Nigel Horne 2004-11-03 10:33:50 EST
When will 2.1.16 be available? up2date reports no updates at the moment.
Comment 3 Matthew Miller 2006-06-29 22:38:35 EDT
Looks like an update never was produced for FC2, but rather only FC3 on. At this
point, FC2 doesn't use rhn for updates anyway. Marking closed as "NEXTRELEASE".

Note You need to log in before you can comment on or make changes to this bug.