This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 136091 - python cannot find HTML documentation
python cannot find HTML documentation
Status: CLOSED DUPLICATE of bug 128030
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-17 15:45 EDT by Behdad Esfahbod
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2004-10-17 15:45:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
Python cannot find HTML documentation.
There are two ways to solve the probelm:

  * python-docs can install python-docs.sh and python-docs.csh in
/etc/profile.d to set PYTHONDOCS variable.  The downside of this is
that it;s run by every shell, while an export at the login time is
enough.  If don't export, then non-interactive python sessions don't
see the documentation.

  * Fix the default path that is looked in by python at compile time
if such a path exists.  After strace'ing, seems like it looks in
/usr/Resources/English.lproj/Documentation/lib!

Version-Release number of selected component (if applicable):
2.3.3-6

How reproducible:
Always

Steps to Reproduce:
[behdad@home behdad]$ rpm -q python
python-2.3.3-6
[behdad@home behdad]$ rpm -q python-docs
python-docs-2.3.3-6
[behdad@home behdad]$ python
Python 2.3.3 (#1, May  7 2004, 10:31:40)
[GCC 3.3.3 20040412 (Red Hat Linux 3.3.3-7)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> help("for")
 
Sorry, topic and keyword documentation is not available because the Python
HTML documentation files could not be found.  If you have installed them,
please set the environment variable PYTHONDOCS to indicate their location.
 
>>>
[behdad@home behdad]$ export
PYTHONDOCS=/usr/share/doc/python-docs-2.3.3/html
[behdad@home behdad]$ python
Python 2.3.3 (#1, May  7 2004, 10:31:40)
[GCC 3.3.3 20040412 (Red Hat Linux 3.3.3-7)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> help("for")
(manual shows up) 
Related help topics: break, continue, while
 
>>>
[behdad@home behdad]$



Additional info:
Comment 1 Mihai Ibanescu 2004-10-17 16:15:53 EDT
This has been fixed in FC3.
From the changelog:

* Fri Jul 30 2004 Mihai Ibanescu <misa@redhat.com> 2.3.4-6
 
- Fixed #128030 (help() not printing anything)


*** This bug has been marked as a duplicate of 128030 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:23 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.