Bug 136129 - Korean directory name display to "???????" in Locale UTF-8.
Korean directory name display to "???????" in Locale UTF-8.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 137435 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 02:16 EDT by sangu
Modified: 2013-07-02 19:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.6.1-0.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 07:54:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mc in Korean directory name. (31.95 KB, image/png)
2004-10-18 02:18 EDT, sangu
no flags Details
Request bash script by Jindrich (66 bytes, text/plain)
2004-10-21 11:04 EDT, sangu
no flags Details

  None (edit)
Description sangu 2004-10-18 02:16:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041016
Firefox/0.10.1

Description of problem:
Korean directory name  display to "???????" in Locale UTF-8.

Version-Release number of selected component (if applicable):
mc-4.6.1-0.7

How reproducible:
Always

Steps to Reproduce:
1. Execute mc in directory with Korean name.
2.
3.
    

Actual Results:  Display to "??????"

Additional info:

Locale ko_KR.UTF-8, 
Korea directory name is encoded to UTF-8/
Comment 1 sangu 2004-10-18 02:18:18 EDT
Created attachment 105365 [details]
mc in Korean directory name.
Comment 2 Leonard den Ottolander 2004-10-19 06:06:19 EDT
Known issue. The fixes to the UTF-8 patch should fix this.

Jindrich, you should use the original (but fixed against CVS) utf8
patch, plus Vladimir's utf8-fix, utf8-hints and utf8-input patches.
Together these should fix most utf8 issues, and issues with other locales.

Sangu, please also tell which terminal you use as that might also make
a difference. And make sure you set input to 8 bits.

Jindrich, wrt this you might want to use SuSE's 8bit patch. Take from
one of their srpms, or from
http://www.ottolander.nl/mc-patches/suse91/full/mc-4.5.55-8bits_input.patch
.
Comment 3 Jindrich Novy 2004-10-20 16:47:46 EDT
Sangu,

please try out the newest version I have built today: mc-4.6.1-0.8. We
have there all the recommended UTF8 patches so I think this should be
fixed in this release. I cannot test it as I don't understand Korean.
Please let me know if that helped.

cheers,
Jindrich

Comment 4 sangu 2004-10-21 09:35:05 EDT
This problem still happen in mc-4.6.1-0.8,
and  current mc package not view and not edit Korean unicode document.
Comment 5 sangu 2004-10-21 09:44:49 EDT
Sorry, my mistaken posting. 
mc-4.6.1-0.8 can edit and view unicode document.

But the problem still happenes in directory with Korean name.

Comment 6 Jindrich Novy 2004-10-21 10:43:31 EDT
Ok, I have to test it somehow in order to do some fixup for this.
Could you please post here (as an attachment) a simple bash script
that only creates a Korean named directory in an actual path? It will
help me much to investigate the whole thing and help you get rid of
the issue.

Thanks, Jindrich
Comment 7 sangu 2004-10-21 11:04:37 EDT
Created attachment 105590 [details]
Request bash script by Jindrich

Test in en_US.UTF-8 or ko_KR.UTF-8

(My first script for all my linux life)
Comment 8 Jindrich Novy 2004-10-22 03:01:23 EDT
Sangu, congratulations for the first bash script! Thanks for it, now
I'm able to reproduce the bug. I'll try to fix it today.
Comment 9 Jindrich Novy 2004-10-22 04:27:11 EDT
The error was in the second part of uglydir patch. The is_printable()
function returns that the Korean characters are not printable, so
question marks are displayed instead of them. Since a case noticed in
bug 127164 does not occur when UTF8 is enabled, I dropped the second
part of the uglydir patch and it is displayed correctly now.
Comment 10 Leonard den Ottolander 2004-10-23 10:25:31 EDT
Jindrich, can you please submit the (fixed) uglydir patch upstream? TIA.
Comment 11 Leonard den Ottolander 2004-10-28 13:33:15 EDT
*** Bug 137435 has been marked as a duplicate of this bug. ***
Comment 12 Jindrich Novy 2004-11-08 07:54:55 EST
Fixed in mc-4.6.1-0.9.

Note You need to log in before you can comment on or make changes to this bug.