This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 136134 - There is no kernel-source-xxx.i686.rpm or kernel-source-xxx.ia64.rpm in RHEL 4 Beta 1
There is no kernel-source-xxx.i686.rpm or kernel-source-xxx.ia64.rpm in RHEL ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Burke
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 03:32 EDT by L3support
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 09:20:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-10-18 03:32:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
  There is no kernel-source-xxx.i686.rpm or kernel-source
-xxx.ia64.rpm in RHEL 4 Beta 1. Therefore We can't compile 
the third party driver. We need kernel-source-xxx.i686.rpm
or kernel-source-xxx.ia64.rpm in RHEL 4 Beta 1.

  These RPM would be developed as a source corresponding to
the kernel being installed in /usr/src/linux now.
As a result the third party driver can be compiled by these RPM.

  Thank you for your consideration.

Version-Release number of selected component (if applicable):
kernel-2.6

How reproducible:
Always

Steps to Reproduce:
Refer the description of problem

Actual Results:  Refer the description of problem

Expected Results:  We can get kernel-source-xxx.i686.rpm or kernel-
source-xxx.ia64.rpm in RHEL 4 Beta 1.

Additional info:

Business Impact: Our developing product is influenced by this problem.
Comment 1 Rik van Riel 2004-10-18 08:56:24 EDT
The header files needed to compile external kernel modules are located
in /lib/modules/<version>/build/
Comment 2 L3support 2004-10-19 02:10:11 EDT
 We appreciate to your quick reply.
But our problem hasn't been solved yet.
We really want to know the reason why there is 
no kernel-source-xxx.i686.rpm or kernel-source-xxx.ia64.rpm 
in RHEL 4 Beta 1. As everybody knows kernel-source-xxx.xxx.rpm 
is existed in RHEL 3 and RHEL 2.1 . 
To develop our new software we need to get kernel-source-xxx.i686.rpm
or kernel-source-xxx.ia64.rpm. Therefore tell us the reason 
why kernel-source isn't provided this time.
And also is there any way to get kernel-source-xxx.i686.rpm and
kernel-source-xxx.ia64.rpm.
Comment 3 Rik van Riel 2004-10-19 07:58:02 EDT
The header files needed for the development of kernel drivers are in
/lib/modules/`uname -n`/build/

What other part of the kernel sources do you need for the development
of your software ?
Comment 4 L3support 2004-10-19 21:36:09 EDT
 We appreciate to your quick reply again.
For developing our software we need all kernel sources which 
are provided from kernel-source-xxx.i686.rpm and 
kernel-source-xxx.ia64.rpm. Because that's the way 
we have done developing since RHEL 2.1 and RHEL 3.
As We have asked you last time please tell us the reason 
why kernel-source isn't provided this time. 
Is there a way to get kernel-source-xxx.i686.rpm and 
kernel-source-xxx.ia64.rpm ?
Comment 5 Rik van Riel 2004-10-19 22:18:38 EDT
You can create the kernel source tree from the kernel src.rpm.

The reason there is no special kernel source RPM is that there is also
no source code RPM for any other package in the distribution, since
the .src.rpm packages already exist.

All the header files and configuration files needed to build any
external kernel driver are included in the kernel RPM itself, and
located in /lib/modules/`uname -r`/build/

In order for us to be able to give you the files you need (if there
are any important files missing), you will need to tell us what those
files are.
Comment 6 L3support 2004-10-20 02:17:28 EDT
 We really appreciate to your quick reply again.
We quite understood by now that you people aren't intending to
provide kernel source RPM in RHEL 4 Beta 1.
Because the kernel src.rpm is provided.

 How about the Gold Master of RHEL 4(I mean formal version. 
Not Alpha or Beta) ?
Is there any possbililty that the kernel source RPM is provided 
in the Gold Master of RHEL 4 ?
Comment 7 Arjan van de Ven 2004-10-20 09:20:01 EDT
No.

Note You need to log in before you can comment on or make changes to this bug.