Bug 136146 - lots of missing return statememts + 1 local variable problem
lots of missing return statememts + 1 local variable problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 07:42 EDT by David Binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: dhcpv6-0.10-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 15:41:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-10-18 07:42:58 EDT
Description of problem:

I just tried to compile package dhcpv6-0.10-7 from package
Redhat Fedora Core 3 Test 3.

The compiler said

1.

dad_token.l(198): warning #1011: missing return statement at end of
non-void function "dad_parse"

The source code is

        yylex();
}

Suggest add return statement.

2.

ra_token.l(175): warning #1011: missing return statement at end of
non-void function "ra_parse"

Duplicate.

3.

resolv_token.l(163): remark #592: variable "pid" is used before its
value is set

The source code is

    if( (pid == fork()) < 0 )

Maybe

    if( (pid = fork()) < 0 )

was intended ?

4.

resolv_token.l(243): warning #1011: missing return statement at end of
non-void function "resolv_parse"
resolv_token.l(363): warning #1011: missing return statement at end of
non-void
function "yywrap"
radvd_token.l(284): warning #1011: missing return statement at end of
non-void function "radvd_parse"
radvd_token.l(344): warning #1011: missing return statement at end of
non-void function "yywrap"

Duplicates.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jason Vas Dias 2004-10-18 15:41:43 EDT
These issues (and more compiler warnings) are now 
fixed in dhcpv6-0.10-8 .

Note You need to log in before you can comment on or make changes to this bug.