Bug 136151 - ifdown script leaves dhcpcd running if BOOTPROTO changed while interface is up
ifdown script leaves dhcpcd running if BOOTPROTO changed while interface is up
Status: CLOSED DUPLICATE of bug 136465
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 08:13 EDT by Neil Horman
Modified: 2014-03-16 22:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to kill appropriate dhcpcd|pump client after iface config has changed (395 bytes, patch)
2004-10-18 08:14 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2004-10-18 08:13:24 EDT
Description of problem:
If an interface is ifup-ed with a config indicating
BOOTPROTO=[dhcp|bootp], and then the config is changed such that
BOOTPROTO=static, the dhcpcd or pump daemon is left running when
service network restart is run, leading to undesired interface address
changes

Version-Release number of selected component (if applicable):
all

How reproducible:
allways

Steps to Reproduce:
1.config an interface to use dhcp or bootp
2.start the interface with service network restart or ifup
3.reconfig the interface such that BOOTPROTO=static
4.restart networking service
  
Actual results:
dhcpcd|pump is left running, and eventually the ip address will change
on the interface when the lease is renewed

Expected results:
dhcpcd|pump should be killed

Additional info:
Comment 1 Neil Horman 2004-10-18 08:14:57 EDT
Created attachment 105371 [details]
patch to kill appropriate dhcpcd|pump client after iface config has changed

This corrects the ifdown script to detect if a dhcpcd client is running on an
interface regardless of its current config, allowing the client to be properly
killed after its BOOTPROTO has changed.
Comment 2 Bill Nottingham 2004-10-18 12:12:58 EDT
Technically, this doesn't handle pump. :)
Comment 4 Neil Horman 2004-10-18 13:02:53 EDT
Good point, I hadn't considered the use of all the various dhcp
clients.  I guess it would need to have an or clause for each of the
dhcp clients that ifup/down supports :)
Comment 6 Bastien Nocera 2004-10-20 05:48:35 EDT

*** This bug has been marked as a duplicate of 136465 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:06:24 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.