Bug 13617 - linuxconf disagrees with system configuration
linuxconf disagrees with system configuration
Status: CLOSED DUPLICATE of bug 14350
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.1
i386 Linux
high Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-08 22:44 EDT by Jay Freeman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-08 22:45:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Freeman 2000-07-08 22:44:57 EDT
When you first run linuxconf and exit it (I made a change to my LILO 
configuration, didn't view or change anything else, but this shouldn't 
make a difference), linuxconf wants to make the following changes (as seen 
from the "activate changes" dialog):

Changing permissions  of file /etc/shadow from 100600 to 100400
Changing permissions  of file /usr/sbin/sendmail from 104555 to 106755
Changing owner of file /var/spool/mqueue to root.root
Changing permissions  of file /usr/sbin/sendmail from 104555 to 106755
Changing permissions  of file /usr/bin/pppd from 100755 to 104755
Changing owner of file /var/spool/uucp to uucp.root
... execute a bunch of rc scripts ...

I would think that if linuxconf is supposed to be a good way of changing 
things, it should agree with the installed system configuration and not go 
changing things (like making pppd setuid root when it doesn't come like 
that, which seems like a really really bad thing, and is the brunt of the 
reason I made this "high" priority instead of "low").

I agree with what it is doing to /etc/shadow, however, and would like to 
know why /etc/shadow is now coming 600 instead of 400...
Comment 1 Tim Waugh 2000-07-27 08:37:46 EDT

*** This bug has been marked as a duplicate of 14350 ***

Note You need to log in before you can comment on or make changes to this bug.