Bug 136215 - (IT#53849) krfb per KDE's "desktop sharing" crashes when vncviewer disconnects
krfb per KDE's "desktop sharing" crashes when vncviewer disconnects
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdenetwork (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-10-18 15:10 EDT by Joshua Jensen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.1.3-1.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 15:06:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
krfb backtrace from the graphical KDE crash handler (1.65 KB, text/plain)
2004-10-18 15:11 EDT, Joshua Jensen
no flags Details

  None (edit)
Description Joshua Jensen 2004-10-18 15:10:34 EDT
Description of problem:

Desktop Sharing crashes with signal 11.

Version-Release number of selected component (if applicable):

RHEL3 U2 for x86 with all updates

How reproducible:

Go to the KDE control center, under "Internet & Network" you'll find
"Desktop Sharing" and there enable the options "Allow uninvited
connection" and "Allow uninvited connections to control the desktop".
Disable the other options ("Confirm..." and "Announce...").

Now connect to the machine:0 from vncviewer on another machine.
It works... but then disconnect.  Boom!  krfb crashes, and you can't
reconnect.
Comment 1 Joshua Jensen 2004-10-18 15:11:52 EDT
Created attachment 105393 [details]
krfb backtrace from the graphical KDE crash handler
Comment 2 Joshua Jensen 2004-11-02 12:11:21 EST
ping.... hello?
Comment 3 Ngo Than 2004-11-02 16:53:55 EST
your backtrace does not contain any helpfull infos about the crash.

I will try to reproduce this problem first.
Comment 4 Ngo Than 2004-11-03 11:10:51 EST
Joshua, could you please install the kdelibs/kdebase debug packages
and try to get better backtrace please. I don't have x86_64 machine
for doing that. Thanks
Comment 5 Joshua Jensen 2004-11-03 12:40:23 EST
x86_64 ??  I'm missing the significance of that... this *isn't* where
I've seen the problem.

Also, where do I get the debug packages from?
Comment 6 Joshua Jensen 2004-11-03 12:40:59 EST
Can you reproduce the problem on i386 platform?
Comment 7 Ngo Than 2004-11-10 13:03:17 EST
yes, i can reproduce it on i386. it's now fixed in 3.1.3-1.6.
Comment 8 Joshua Jensen 2004-11-10 13:34:31 EST
Ok.... what was the root cause?
Comment 11 Joshua Jensen 2005-12-28 11:09:11 EST
???

One Year Ping!!!
Comment 12 Joshua Jensen 2006-03-14 10:51:22 EST
Once you tell us what the actual problem was, let's close the case!


ping pinga pppping

??
Comment 13 Ngo Than 2006-03-14 14:42:10 EST
please take a look at http://bugs.kde.org/show_bug.cgi?id=61904

Note You need to log in before you can comment on or make changes to this bug.