Bug 136239 - 3 * array subscript out of range
3 * array subscript out of range
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 16:25 EDT by David Binderman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 03:07:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-10-18 16:25:01 EDT
Description of problem:

I just tried to compile package ethereal-0.10.6-2 from package
Redhat Fedora Core 3 Test 3.

The compiler said

1.

packet-rtcp.c(294): warning #175: subscript out of range

The source code is

               p_conv_data->method[MAX_RTCP_SETUP_METHOD_SIZE] = '\0';

Suggest

               p_conv_data->method[ MAX_RTCP_SETUP_METHOD_SIZE - 1] =
'\0';

might be better.

2.

packet-rtp.c(238): warning #175: subscript out of range

The source code is

                p_conv_data->method[MAX_RTP_SETUP_METHOD_SIZE] = '\0';

Here again,

                p_conv_data->method[MAX_RTP_SETUP_METHOD_SIZE - 1] = '\0';

is suggested.

3.

gsm_map_stat.c(448): warning #175: subscript out of range

The source code is

        dlg.entries[10] = g_strdup("0");

I'm not sure what the fix is for this.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Radek Vokal 2004-10-19 03:07:01 EDT
This seems to be fixed in upstream version of ethereal-0.10.7. I'm
waiting for stable version to include it in FC3. 
Comment 2 David Binderman 2005-03-10 05:05:00 EST
>This seems to be fixed in upstream version of ethereal-0.10.7. I'm
>waiting for stable version to include it in FC3. 

FC3 has been and gone.

The first two parts of the bug report seem to be fixed, which is good
news, but I can confirm that the third part of the bug report
is still broken in the version after FC3, i.e. March 2005.
Comment 3 David Binderman 2005-05-25 09:41:09 EDT
>but I can confirm that the third part of the bug report
>is still broken in the version after FC3, i.e. March 2005.

Still broken in Fedora Core 4 Test 3, dated May 2005.

Note You need to log in before you can comment on or make changes to this bug.