Bug 136241 - 2 * missing return statements
2 * missing return statements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: exim (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 16:26 EDT by David Binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 05:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Binderman 2004-10-18 16:26:56 EDT
Description of problem:

I just tried to compile package exim-4.42-2 from package
Redhat Fedora Core 3 Test 3.

The compiler said

1.

header.c(33): warning #117: non-void function "header_insert" should
return a value

The source code is

if (header_last == NULL) return;

Suggest add expression to the return statement.

2.

header.c(34): warning #117: non-void function "header_insert" should
return a value

The source code is

if (header_list == NULL) return;

Duplicate.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas Woerner 2004-10-20 05:06:37 EDT
Please updates to the latest fc3 package: exim-4.43-1
The problem is already fixed in this version.

Note You need to log in before you can comment on or make changes to this bug.