Bug 136244 - linking vs python for software that uses dynamic modules is broken in two ways
linking vs python for software that uses dynamic modules is broken in two ways
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 16:44 EDT by rudolf kastl
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 12:02:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rudolf kastl 2004-10-18 16:44:09 EDT
Description of problem:

Version-Release number of selected component (if applicable):
2.3.3-6

How reproducible:
always

Steps to Reproduce:
link some software vs python that uses python dynamic modules
statically or dynamically. both ways are broken.

1. statically
the dynamic modules arent compiled into the static lib. no workie.

2. dynamically
lots of problems since the open office shared lib is another version.

Actual results:
no workie

Expected results:
atleast one non broken way without rebuilding python and breaking stuff.

Additional info:
id recommend to atleast build the dynamic modules into the shared
library else its pretty useless.
Comment 1 rudolf kastl 2004-10-18 16:45:15 EDT
correction for additional info:

id recommend to atleast build the dynamic modules into the static
library else its pretty useless.

sorry. please ignore the sentence in the initial report ;)
Comment 2 Mihai Ibanescu 2004-10-27 09:49:36 EDT
Can you please give an example I can work with?
Comment 3 Mihai Ibanescu 2005-09-30 12:02:57 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product. If this has not been fixed in newer releases,
please feel free to re-open the bug report and provide more information that
would help us fix it.

Note You need to log in before you can comment on or make changes to this bug.