Bug 13625 - anacron "FAILED" on shutdown
Summary: anacron "FAILED" on shutdown
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anacron
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 14274 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-09 16:04 UTC by Gene Czarcinski
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-07-09 19:30:25 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2000-07-09 16:04:58 UTC
Created a beta2 system with kde and gnome.  Booted the new system and
changed some configuration -- (vmware xserver) and /etc/inittab.  Rebooted
the system.

Brought up the new system and let it just "sit" for about ten minutes. 
When I rebooted the system again, a message during shutdown indicated that
anacron shutdown "FAILED".

Comment 1 Jay Freeman 2000-07-09 19:30:23 UTC
Considering anacron isn't a daemon and unless it is working on something that 
is taking a long time normally wouldn't be running during shutdown, it doesnt 
seem appropriate to show a [  FAILED  ] notice for stopping anacron.  Might as 
well leave it alone and let it get hit with all the other process as a 
TERM/KILL is sent.

Is it even a good idea to have anacron run at that point in the startup 
anyway?  A script placed in /etc/cron.* might require another service that 
isn't running, such as a database server, a web server, a news server, etc.  
Currently anacron is being started even before networking is up...

Comment 2 Bernhard Rosenkraenzer 2000-07-10 20:10:29 UTC
Fixed in 2.3-5.
It's treated like a daemon because we want it to be run at runlevel changes
(cron is not necessarily running in runlevel 1); someone messed up the ifs while
moving over to the new start() scheme.

Comment 3 Glen Foster 2000-07-19 14:06:12 UTC
*** Bug 14274 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.