Bug 13627 - change kde config produces dcopserver error msg
change kde config produces dcopserver error msg
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdelibs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-09 13:28 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-15 12:27:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-07-09 13:28:21 EDT
I built a beta3 system with gnome and kde installed.  I booted up runlevel
5 (since switchdesk-kde does nothing), and logged on as a normal user with
kde selected.  Everything looked fine.  I then logged off and back on --
everything still OK.  I then used the KDE Control Center to change some
configurations -- desktop color, enabling color buttons for kpanel, and
selecting a them such as the HighColor Default.  Evenything looked OK with
the new configuration.  I then logged off and back on -- at kde startup, I
got an error message in a panel:

DCOP Communication Error ()

There was some error setting up inter-process communications for KDE.  The
message returned by the system was:

Could not read network connection list

Please check that the "dcopserver" program is running! [it was].
Comment 1 Gene Czarcinski 2000-07-09 16:22:13 EDT
More info ...

This problem does NOT depend on changing anything.  However, it may be some kind
of timing problem (race condition).

When I run under vmware (looking like a slow up), kde sort of works -- OK the
first time but then I start getting dcopserver error messages when I re-login.

On real hardware, it is a bit different --

I built a fresh beta3 system with gnome & kde.  I then booted up (runlevel 5)
and select kde and logged in as a normal user, it works.  I then logoff which
changing anything or even saving the session.  When I log back in, I get a great
gray screen with the kde-intro panel displayed.  I ctl-alt-backspace to get out
and try again -- same thing.

I then reboot and login.  This time I get kde to "sort of" start .. the window
manager comes up but I get the dcopserver error msg.

I can play with this some more if you need more info.  I am hoping that you can
duplicate the problem.

Gene
Comment 2 Gene Czarcinski 2000-07-09 16:36:40 EDT
The following is from the kde mailing lists --

List:     kde-devel
Subject:  Re: DCOPServer?
From:     David Faure <david@mandrakesoft.com>
Date:     2000-07-03 18:27:54
[Download message RAW]

On Mon, Jul 03, 2000 at 06:26:11PM +0200, Wim Stubbe wrote:
> > > Session management error: networkIdsList argument is NULL
> > 
> > That's a well known warning, not harmfull at all
> > (and hopefully fixed in the next Qt !)
> > Look somewhere else for why it doesn't start...
> > 
> > > I think that KDE refuses to start due to that problem, but
> > > I'm not sure about that. (It starts till kwin registers
> > > and hangs then).
> > > 
> > > It worked a few days ago. Do you have an idea?
> > 
> > Nothing else in the debug output ?
> 
> 
> I now have the same problem, didn't find anything yet, but I'm rebuilding
> everything now.
> and indeed, nothing in the debug output. :-(

Yes there is.
kdeinit: error in loading shared libraries: Instance: cannot open shared object
file: \
No such file or directory 

That was because of the "Instance kdeinit has not data" warning that screwed
up LD_PRELOAD=`kdeinit --libkmapnotify`. Hehe.
Fixed.

-- 
David FAURE, david@mandrakesoft.com, faure@kde.org

I guess I have to wait for beta4 to get a fix.

Gene
Comment 3 Michael Redinger 2000-07-15 12:26:05 EDT
Same here - however, it always happens. I did a complete install. The machine
I'm running this on is a Dell OptiPlex GX1 (P 450 and 64 MB RAM, ATI Rage Pro
card).

When doing a telinit 5 I found the following messages:

kio (Ksycoca): No databse, opening a dummy one.
Instance kdeinit has no about data
Aborting. $HOME not set!

(don't know if this is relevant ...).

I checked and did not find any dcopserver process. Starting it manually does not
change anything, same message still.
Comment 4 Michael Redinger 2000-07-15 12:27:04 EDT
Oops, forgot this one:

When starting dcopserver manually I do get the following message:

Session management error: networkIdsList argument is NULL
Comment 5 Bernhard Rosenkraenzer 2000-07-17 07:29:38 EDT
This is fixed in the current version.
Comment 6 David Balažic 2000-07-20 13:22:03 EDT
I installed X11 and KDE ( as the only package groups ) from beta3.

On next(first) boot the kdm login screen appeared with a dialog in
front saying :
---------
There was some error setting up inter-process
communications for KDE. The message returned
by the system was:

 Could not read network connection list.

Please check that the "dcopserver" program is running !

                  [ OK ]
---------
Comment 7 Bernhard Rosenkraenzer 2000-07-20 13:33:10 EDT
Like I've already said, the version in beta3 was buggy. It's fixed in the
current version.

Note You need to log in before you can comment on or make changes to this bug.