Bug 136276 - files with unexpected coding in /usr/share/texmf/
files with unexpected coding in /usr/share/texmf/
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tetex (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-18 23:23 EDT by Michal Jaegermann
Modified: 2013-07-02 19:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.0.2-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 09:45:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-18 23:23:56 EDT
Description of problem:

Files /usr/share/texmf/Changes.txt and /usr/share/texmf/README.txt
pretend to be regular text files but actually they have somewhat
surprising coding.  For the first one emacs is able to figure out
that this is a Japanese text coded in iso-2022-jp-unix.  The
other one baffles even emacs while 'file' claims 
"README.txt: ISO-8859 text" and this is clearly not the case.
It seems to be some Japanese text as well.

At least COPYRIGHT.jis in the same directory does not leave
any doubts. :-)  It is in iso-2022-jp-unix too while README.txt
is using definitely some other encoding and it does not seem to
be utf-8 as well.

Version-Release number of selected component (if applicable):
tetex-2.0.2-21
Comment 1 Jindrich Novy 2004-10-25 09:45:00 EDT
Michal,

the README.txt is in euc-jp encoding, so to keep all the encodings
apparent I converted all the Japanese files Changes.txt, README.txt to
iso-2022-jp and renamed them to Changes.txt.jis and README.txt.jis.

Thanks

Note You need to log in before you can comment on or make changes to this bug.