Bug 136281 - /etc/xpdfrc obsolete in comparison with used xpdf version
/etc/xpdfrc obsolete in comparison with used xpdf version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-19 00:40 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 04:52:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-10-19 00:40:46 EDT
Description of problem:

Uncommenting in /etc/xpdfrc lines

#t1libControl           low
#freetypeControl        low

which looks like a reasonable action, results in the following:

Error: Unknown config file command 't1libControl' (/etc/xpdfrc:105)
Error: -- The t1libControl and freetypeControl options have been replaced
Error:    by the enableT1lib, enableFreeType, and antialias options
Error: Unknown config file command 'freetypeControl' (/etc/xpdfrc:106)
Error: -- The t1libControl and freetypeControl options have been replaced
Error:    by the enableT1lib, enableFreeType, and antialias options

These lines really should read

# enableT1lib    yes
# enableFreeType yes
# antialias      yes

Also /etc/xinitrc does not redefine 'urlCommand' which likely
should be defined in terms of htmlview (or a script which peeks
directly into gconf data).

BTW, putting in /etc/xpdfrc a line 'enableT1lib no', or calling
xpdf as 'xpdf -t1lib no -freetype yes -aa yes ....', allows to
display a file from bug #118361.  '-aa no' works as well but
results look quite unattractive. :-)  With '-freetype no' only
blank pages show up regardles of '-t1lib' settings.

Version-Release number of selected component (if applicable):
xpdf-3.00-8
Comment 1 Ngo Than 2004-10-19 04:52:34 EDT
it's fixed now in xpdf.3.00-9. thanks for your infos.

The xpdf autor has noticed the bug #118361 is caused in t1lib. i think
the t1lib aitor is aware of this problem ;-)

Note You need to log in before you can comment on or make changes to this bug.