Bug 136436 - Incorrect timezone for 2004 brazilian daylight savings time (DST)
Summary: Incorrect timezone for 2004 brazilian daylight savings time (DST)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tzdata (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-20 01:16 UTC by Celso K. Webber
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 06:41:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to change DST for Brazil in 2004. (1.40 KB, patch)
2004-10-20 01:17 UTC, Celso K. Webber
no flags Details | Diff
Modified spec file I used to generate my own updated RPM. (1.42 KB, text/plain)
2004-10-20 01:18 UTC, Celso K. Webber
no flags Details
Patch to change DST for Brazil in 2004. (1.85 KB, patch)
2004-10-20 02:11 UTC, Celso K. Webber
no flags Details | Diff

Description Celso K. Webber 2004-10-20 01:16:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922 Epiphany/1.2.7

Description of problem:
Due to the computerized electoral proceedments in Brazil, daylight
savings time date was postponed in 2004. Since the electoral process
will end in october 31st, dst starting day was postponed to November
2nd this year.

Version-Release number of selected component (if applicable):
2003d-2

How reproducible:
Always

Steps to Reproduce:
1. brazilian uers had their time advanced 1 hour since Oct 15th
2.
3.
    

Actual Results:  After Oct 15th time advanced 1 hour.

Expected Results:  Time should only be advanced by one hour in Nov 2nd.

Additional info:

Patch will and modified spec attached.

Comment 1 Celso K. Webber 2004-10-20 01:17:46 UTC
Created attachment 105482 [details]
Patch to change DST for Brazil in 2004.

Comment 2 Celso K. Webber 2004-10-20 01:18:58 UTC
Created attachment 105483 [details]
Modified spec file I used to generate my own updated RPM.

Comment 3 Celso K. Webber 2004-10-20 02:11:16 UTC
Created attachment 105487 [details]
Patch to change DST for Brazil in 2004.

Comment 4 Jakub Jelinek 2004-10-20 06:41:03 UTC
Isn't it easier to just update to tzdata-2004e-1.fc2 that has been
released as FC2 update a week ago?
http://www.redhat.com/archives/fedora-announce-list/2004-October/msg00008.html

Comment 5 Celso K. Webber 2004-10-21 00:11:30 UTC
Sorry, friend. I had up2dated my machine and it didn't report me any
updated package.

I thought it wasn't updated in Fedora Core, since all my customers who
use Red Hat EL v3 had this problem. There is NO update for this
problem under RHEL v3, is there?

Sorry for disturbing you again, next time I'll do more researching
before posting a bug.


Note You need to log in before you can comment on or make changes to this bug.