Bug 136463 - squid can't read errors files under targeted policy
Summary: squid can't read errors files under targeted policy
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-20 09:30 UTC by Alexandre Oliva
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-23 16:38:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2004-10-20 09:30:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; rv:1.7.3)
Gecko/20041016 Firefox/0.10.1

Description of problem:
After upgrading to 2004-10-19's rawhide, plus kernel 2.6.9-1.637,
squid will no longer start up.  /var/log/messages says:

audit(1098263269.203:0): avc:  denied  { search }
for  pid=10229 exe=/usr/sbin/squid name=nscd dev=dm-2 ino=1425498
scontext=root:system_r:squid_t
tcontext=system_u:object_r:nscd_var_run_t tclass=dir
audit(1098263269.203:0): avc:  denied  { search }
for  pid=10229 exe=/usr/sbin/squid name=nscd dev=dm-2 ino=1425498
scontext=root:system_r:squid_t
tcontext=system_u:object_r:nscd_var_run_t tclass=dir
audit(1098263269.204:0): avc:  denied  { read } for  pid=10229
exe=/usr/sbin/squid name=errors dev=dm-2 ino=525753
scontext=root:system_r:squid_t tcontext=system_u:object_r:squid_conf_t
tclass=lnk_file
Error Directory /etc/squid/errors: (13) Permission
denied

It appears that the latest policy changes modified /etc/squid/errors
from system_u:object_r:etc_t, that could be followed, to
::squid_conf_t, that can't.

Version-Release number of selected component (if applicable):
squid-2.5.STABLE6-3 selinux-policy-targeted-1.17.30-2.2

How reproducible:
Always

Steps to Reproduce:
1.update to selinux-policy-target and squid to the versions above
2.setfiles -v /etc/selinux/targeted/files/file_contexts /etc/squid
(unless you installed selinux-policy-target as a separate rpm
transaction, before squid)
3.service squid restart

Actual Results:  squid crashes because it can't load the errors files.

Expected Results:  it should work

Additional info:

chcon -h system_u:object_r:etc_t /etc/squid/errors enables squid to
start again.

Comment 1 Daniel Walsh 2004-10-20 14:28:43 UTC
Fixed in selinux-policy-targeted-1.17.30-2.6


Note You need to log in before you can comment on or make changes to this bug.