Bug 13647 - LPRng staircases ascii output
LPRng staircases ascii output
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-10 13:14 EDT by David Lawrence
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-14 11:47:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Tattersall 2000-07-10 13:14:24 EDT
Setting up LPRng with the same printcap and print filters and
/var/spool/lpd structure as is provided by Red Hat IT, LPRng staircases an
ascii file, while LPR prints it correctly.  This was verified by using the
lpr package from RHL6.2  with the RH IT print setup,  and the same setup
with LPRng.
Comment 1 Bill Nottingham 2000-07-11 01:05:18 EDT
Does turning on 'fix stair-stepping text' in printtool fix it?
Comment 2 Preston Brown 2000-07-13 15:21:25 EDT
I don't think so.

Nalin is working on this now.
Comment 3 Derek Tattersall 2000-07-14 09:19:26 EDT
The -3 version in the tree on 14 JUL still exhibits the problem.
Comment 4 Hans de Goede 2000-07-14 11:47:05 EDT
I've signed up as tester for this package, and I'm trying to reproduce the bugs
reported on it now,
as I read this the problem happens after an upgrade. (Since the old printcap and
stuff is still in place). I find this strange since it works for me (TM), could
you please provide some more details like printcap and ls -alR /var/spool/lpd
output? (Or maybe even an tar of /var/spool/lpd)
Comment 5 Nalin Dahyabhai 2000-07-19 11:51:28 EDT
The problem was only exhibited when the printer itself needed
that option enabled.  It's a side-effect of rhs-printfilters needing
tweaking to work with LPRng.  Should be fixed now, though the
upgrade case needs closer examination.
Comment 6 Hans de Goede 2000-07-19 15:15:03 EDT
It has worked fine for me since beta1, and my printer does need this feature.
So I think it is upgrade case related not sure though.

Note You need to log in before you can comment on or make changes to this bug.