Bug 136531 - initscripts parse ONBOOT and MASTER incorrectly
initscripts parse ONBOOT and MASTER incorrectly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 150710 (view as bug list)
Depends On:
Blocks: 132991 132992 137160
  Show dependency treegraph
 
Reported: 2004-10-20 15:24 EDT by Chris Williams
Modified: 2014-03-16 22:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-129
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 11:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifup patch (1.89 KB, patch)
2004-10-20 15:27 EDT, Chris Williams
no flags Details | Diff

  None (edit)
Description Chris Williams 2004-10-20 15:24:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
ifup script takes different paths depending on ONBOOT being set to "no"
vs
"NO." Changing
   if [ "foo$2" = "fooboot" -a "${ONBOOT}" = "no" -o "${ONBOOT}" = "NO"
]
to
   if [ "foo$2" = "fooboot" ] && [ "${ONBOOT}" = "no" -o "${ONBOOT}" =
"NO" ]
seemed to resolve it.

Also, commented lines in ifcfg-eth* files containing "#MASTER"
cause theinterface to be brought up. This is because "MASTER=${DEVICE}"
is grepped for which detects commented lines causing the interface to
be brought up when ifup is called without "boot" as the second
argument. Changing
   for device in `fgrep -l "MASTER=${DEVICE}" 
/etc/sysconfig/network-scripts/ifcfg-*` ; do
to
    for device in `grep -l "^[[:space:]]*MASTER=${DEVICE}" 
/etc/sysconfig/network-scripts/ifcfg-*` ; do
seems to resolve it.



Version-Release number of selected component (if applicable):
initscripts-7.31.16.EL-1

How reproducible:
Always

Steps to Reproduce:
Configure bonding. Try ONBOOT=on or ONBOT=ON in ifcfg-ethx.
Comment MASTER in ifcfg-ethx and bring up bond0.
    

Actual Results:  ONBOOT=on behaves differently than ONBOOT=ON.
Commented lines in ifcfg-ethx files containing "#MASTER"
cause theinterface to be brought up.

Expected Results:  ONBOOT=ON or on, should not be case sensative.
Commenting MASTER should prevent bonding of ethx to the bond interface.

Additional info:
Comment 1 Chris Williams 2004-10-20 15:27:06 EDT
Created attachment 105543 [details]
ifup patch
Comment 4 Bill Nottingham 2005-03-09 17:01:06 EST
*** Bug 150710 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2005-03-17 08:43:12 EST
Fixes confirmed in initscripts-7.93.13.EL-1.
Comment 6 Hubert Lin 2005-03-24 06:01:17 EST
(In reply to comment #5)
> Fixes confirmed in initscripts-7.93.13.EL-1.

Will this fix be included in RHEL4 U1 as well as in RHEL3 U5?

Comment 7 Bill Nottingham 2005-03-24 13:39:09 EST
It's planned, yes.
Comment 8 John Flanagan 2005-04-28 11:21:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-117.html
Comment 9 Tim Powers 2005-05-18 11:35:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-123.html

Note You need to log in before you can comment on or make changes to this bug.