Bug 136553 - Unable to bind cluster to a IP and nodes reboot
Unable to bind cluster to a IP and nodes reboot
Status: CLOSED DUPLICATE of bug 114653
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Depends On:
  Show dependency treegraph
Reported: 2004-10-20 17:20 EDT by Arthur Benoit
Modified: 2009-04-16 16:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Arthur Benoit 2004-10-20 17:20:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
I have a three node cluster running on subnet one. I add 2 additional 
IP subnets for ISCSI to connect storage. When the system is rebooted 
the cluster appears to try and make qurom connections through one of 
ISCSI IP subnets. I am not able to bind the cluster to the subnet 
assigned to the cluster. When the subnets assigned to ISCSI are 
enabled and any of the cluster nodes are started the node will 
reboot. Microsoft's cluster software had the same problem and a new 
feature to bind the cluster to a subnet resolved the issue.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Create a 3 node cluster with a NFS service
2.Add 2 Gig-e adapters 
3.Add the ISCSI (Cisco package) RPM
4.Configure the ISCSI discovery in /etc/iscsi.config
5. restart the cluster nodes
6. Steps 3 and 4 are most likely not needed to recreate this problem.

Actual Results:  The cluster node that was just started rebooted.

Expected Results:  The cluster should have been able to establish the 
qurom with the other two nodes.

Additional info:
Comment 1 Lon Hohberger 2004-11-17 11:30:44 EST
1.2.9 is *very* old.  Please upgrade to 1.2.16 in the Cluster Suite
channel and reproduce.

Furthermore, iSCSI isn't supported yet.

Binding the cluster to a given subnet can be accomplished by adding
/etc/hosts entries for the IP addresses on the subnet your cluster is
intended to communicate over and using those hostnames for your
cluster member names.

When using broadcast heartbeat mode, your cluster will send packets on
several interfaces - regardless of whether or not they are the same
interfaces used by the cluster for actual communication.
Comment 2 Lon Hohberger 2005-01-03 11:15:11 EST
How does this work on 1.2.22, which was released with U4?
Comment 3 Arthur Benoit 2005-01-04 16:18:01 EST
All of my licenses expired on Dec 22, 2004 so I need to work this out 
before I can try the upgrade.

Comment 4 Lon Hohberger 2005-01-10 13:00:44 EST
I'm pretty sure this is a duplicate of the following bug:


Basically, clumanager 1.2.9 reboots if it fails to join a multicast
group after a few seconds.  You should be able to fix this by changing
clumanager to use 'broadcast' instead of multicast heartbeating in the

*** This bug has been marked as a duplicate of 114653 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:06:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.