Bug 136555 - [RFE] Allow search by Name-Version-Release
[RFE] Allow search by Name-Version-Release
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sebastian Skracic
Stephen Herr
US=19864
: FutureFeature
Depends On:
Blocks: 414671 457802
  Show dependency treegraph
 
Reported: 2004-10-20 17:34 EDT by Chris Kloiber
Modified: 2008-09-25 09:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 09:03:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2004-10-20 17:34:37 EDT
Description of problem:

From the errata search page:

https://rhn.redhat.com/network/errata/search.pxt

Try to search for kernel-2.4.21-15.0.4 and select to search by package
name. No results are found.

----

In a related issue, from the list of packaages for a channel:

https://rhn.redhat.com/network/software/channels/packages.pxt?cid=1181

Select any package you want to find an older version of. You are
presented with the information about the latest version of the
package. For instance:

https://rhn.redhat.com/network/software/packages/details.pxt?pid=184112

At the top of the page is a link to "Newer Versions" which of course
is empty, as you are looking at the newest version already. Perhaps it
shold change to "Older Versions" and list the older versions (include
a warning on that page mentioning that these packages are older for a
reason, perhaps list the bug numbers fixed by each and changelog
entries) and give the customer links to download those packages. 

This is important because of bugs where the workaround is to install
the older version until the next Update comes out. Finding older
versions of packages is curently a royal pain.
Comment 2 Sebastian Skracic 2008-08-14 07:21:51 EDT
Errata search by package name/version/release is now implemented in r118937.
It is therefore possible to search for either "kernel", "kernel-2.6.18" or "kernel-2.6.18-92.1.1.el5" in the package name field.  Package architecture (like .i686, .x86_64 etc) or RPM package suffix (.rpm) are simply removed from the end of the search string and ignored.
Comment 3 Sebastian Skracic 2008-08-14 07:23:32 EDT
For RFE regarding "Older versions"/"Newer versions" please submit a separate BZ.  Thanks!
Comment 5 Stephen Herr 2008-09-03 11:32:32 EDT
verified in qa

Note You need to log in before you can comment on or make changes to this bug.