Bug 136564 - Lost greek filename support when upgrading from fc2 to fc3t3!
Lost greek filename support when upgrading from fc2 to fc3t3!
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 136566 136567 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-20 18:11 EDT by George Kakos
Modified: 2015-01-04 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:27:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Kakos 2004-10-20 18:11:45 EDT
Description of problem:
I have fedora core 2 installed. I have 100% greek filename support and
all of my menus show pretty well in greek characters. A couple of days
ago i downloaded fedora core 3 test 3 dvd iso and upgraded. Everything
went fine except the fact that i lost my greek filename support. I've
doublechecked everything and my fstab and locale settings are the same
but no greek filename support.

My fstab is 

LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /dev/shm tmpfs defaults 0 0
none /proc proc defaults 0 0
none /sys sysfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/hda1 /home/george/mounted/WinXP ntfs ro,umask=0222
/dev/hda5 /home/george/mounted/GamesDVD vfat umask=0
/dev/hda7 /home/george/mounted/Essay vfat umask=0
/dev/hdb1 /home/george/mounted/MP3 vfat umask=0
/dev/hda6 /home/george/Games ext3 defaults
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

and my locale is 

LANG=el_GR.UTF-8
LC_CTYPE="el_GR.UTF-8"
LC_NUMERIC="el_GR.UTF-8"
LC_TIME="el_GR.UTF-8"
LC_COLLATE="el_GR.UTF-8"
LC_MONETARY="el_GR.UTF-8"
LC_MESSAGES="el_GR.UTF-8"
LC_PAPER="el_GR.UTF-8"
LC_NAME="el_GR.UTF-8"
LC_ADDRESS="el_GR.UTF-8"
LC_TELEPHONE="el_GR.UTF-8"
LC_MEASUREMENT="el_GR.UTF-8"
LC_IDENTIFICATION="el_GR.UTF-8"
LC_ALL=

Those are the same in fedora core 2 (where greek filename support
works 100% fine) and fedora core3 test 3 ( where greek filename
support doesn't work. So the problem isn't there. Where could it be?

PS to make sure everything is ok i re-installed all of my fonts from
my winxp installation but with no luck.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Have a fedora core 2 installation
2.Upgrade to fedora core 3 test 3 
3. No greek filename support anymore
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-10-20 18:18:58 EDT
What do you mean by 'lost greek filename support' - where are you
seeing the issue?
Comment 2 Bill Nottingham 2004-10-20 18:22:58 EDT
*** Bug 136566 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2004-10-20 18:29:17 EDT
*** Bug 136567 has been marked as a duplicate of this bug. ***
Comment 4 George Kakos 2004-10-21 07:58:25 EDT
I am seing the ussue either when trying to explore my directories from
any browser or even from console!
Comment 5 Bill Nottingham 2004-10-21 12:06:59 EDT
What do you see instead of the file names?
Comment 6 George Kakos 2004-10-21 16:57:50 EDT
I see filenames like ????? ?? ?????? ?? .Each questionmark is for each
greek character.Any ideas?
Comment 7 Bill Nottingham 2004-10-21 17:42:23 EDT
Looks like a font issue.
Did the console work in FC2 as well?

What does your /etc/sysconfig/i18n look like?
Comment 8 George Kakos 2004-10-21 17:48:06 EDT
Yes.Console worked all right in fedora core 2.Now i restored my fedora
core 2 image i made with norton ghost so i am back to fc2 now. I'll
upgrade again tomorrow to see again what happens and i'll post my
/etc/sysconfig/i18n . Till then thanks for the quick replies and try
thinking what else could it be.
Comment 9 George Kakos 2004-10-23 05:01:54 EDT
I've just re-upgraded and here is my /etc/sysconfig/i18n

LANG="el_GR.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:el_GR.UTF-8:el_GR:el"
SYSFONT="latarcyrheb-sun16"

Should i change anything?Any ideas
Comment 10 George Kakos 2004-10-24 17:22:08 EDT
Anyone?
Comment 11 George Kakos 2004-10-27 18:27:32 EDT
It's been 4 - 5 days and still no answer.That's bad!
Comment 12 Owen Taylor 2004-10-28 09:57:31 EDT
I think the basic problem is that nobody has any ideas whatsoever.

It's pretty much impossible to have anything go wrong that would
kill display of Greek filenames in both the console and in X.

By any chance, is the problem only with your vfat and/or ntfs
partitions? That might imply it has something to do with kernel
mount options / windows code pages.
Comment 13 George Kakos 2004-10-28 18:10:52 EDT
You're right! That only happens whith my vfat and ntfs partitions!
Should i recompile my kernel and if yes what should i check?
Comment 14 Owen Taylor 2004-10-28 19:26:01 EDT
Don't think rebuilding your kernel is necessary. Passing the
right mount options should give you working behavior. Unfortunately,
I'm not really familiar with the details of this area, so I can't
advise you as to what the right ones are. But the combination of
'man mount' and google will hopefully provide the right answer.

Maybe try the 'utf8' option first. And if that doesn't work, experiment
with the 'iocharset' and 'codepage' options.
Comment 15 George Kakos 2004-10-31 11:17:07 EST
You think i haven't?
Comment 16 George Kakos 2004-11-11 04:35:31 EST
Well i completely removed my fc2 and installed last night fc3 from the
begining. The problem is here again! I've figured out that i don't
have greek filename support under fat partitions only. Greek filename
support work 100% right under ext2/3 AND ntfs partitions. I really
think this might be a kernel problem which could only b resolved by
recompiling my kernel and searching for the right option! 

PS I have searched everything but there r no specific directions to
get filename support for fedora core 3 . Only fedora core 2 and of
course other distros.But none of the mentioned procedures work!
Comment 17 Henry Ritzlmayr 2004-11-14 13:30:40 EST
Same thing here with german filenames. 
LANG=de_AT.UTF-8 
since FC3 there is no way of getting german special characters
(umlaut) proper displayed neither in xorg nor in the console.
For every special character the systems displays a ?
I tried several mount options: iocharset=,codepage=, etc. with no luck
Comment 18 Owen Taylor 2004-11-15 14:00:42 EST
Shouldn't this bug be reassigned to kernel? It has nothing to do
with font display, everything to do with charset handling of the
fat/ntfs filesystem modules.

I think it's actually a support (and perhaps release notes) issue,
and that with the right configuration parameters, things would likely
work. But I have no background to know what those right configuration
parameters are.
Comment 19 Nick Lamb 2005-01-18 21:21:35 EST
A quick explanation of what's going on in the kernel AFAIK

Unix filesystems are 8-bit clean and the kernel ignores them, the
userspace (in Fedora Core) treats them as UTF-8 Unicode.

Foreign (non-Unix) filesystems may or may not be 8-bit clean, and have
a variety of semantics for coping with characters outside ASCII (in
some cases even for those inside ASCII). This is mostly handled by the
kernel wide NLS system, and in Fedora Core 3 the CONFIG_NLS_DEFAULT is
utf8, which means e.g CDs and DVDs, NTFS and various other systems
will be treated as UTF-8 more or less like regular Unix filesystems.

FAT family filesystems, apparently including VFAT are treated
separately again (I did not know this when I last ranted on the
subject). They're seemingly controlled by CONFIG_FAT_DEFAULT_IOCHARSET
which claims not to support UTF-8 at all. In Fedora Core 3 these
filesystems are restricted to just ASCII characters by default using
this kernel config option. Changing it is not advisable.

However, if you have files on a VFAT USB stick or a Win9x partition
you can use the mount option "utf8" to enable UTF-8 conversion (yes,
even though it apparently isn't supported by the kernel config
option). Probably the hotplug storage stuff should be updated to do
this by default (but if so it needs a fair amount of testing before
being deployed in some future version of Fedora Core).
Comment 20 Dave Jones 2005-07-15 13:58:51 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 21 Dave Jones 2005-10-02 20:27:11 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.