Bug 136597 - cdrecord fails with cdrecord: Success. send opc: scsi sendcmd: no error
cdrecord fails with cdrecord: Success. send opc: scsi sendcmd: no error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 00:42 EDT by Joe Acosta
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 13:10:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2004-10-21 00:42:05 EDT
Description of problem: cdrecord fails to burn a cd but it says it
succeded and then says it failed to burn

Performing OPC...
cdrecord: Success. send opc: scsi sendcmd: no error
CDB:  54 01 00 00 00 00 00 00 00 00
status: 0x4 (CONDITION MET/GOOD)
cmd finished after 60.730s timeout 60s
cdrecord: OPC failed.
Writing  time:   60.742s
cdrecord: fifo had 64 puts and 0 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.


Version-Release number of selected component (if applicable):

cdrecord-2.01.1-0.FC2.1
[root@Lserver root]# cdrecord --version
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.


How reproducible:  50 / 50 I try to burn a cdrom and 50% of the time
if fails.  Usually the cd-r is hozed and cannot be used anymore.


Steps to Reproduce:
1. make an iso with mkisofs
2. run cdrecord -v speed=2 dev=ATA:1,0,0 <your iso file goes here>
3. it fails
  
Actual results:
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive
dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
TOC Type: 1 = CD-ROM
scsidev: 'ATA:1,0,0'
devname: 'ATA'
scsibus: 1 target: 0 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
SCSI buffer size: 64512
atapi: -1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : '        '
Identifikation : 'COMBO-52X16C    '
Revision       : '2.00'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x0009
Profile: 0x000A
Profile: 0x0009 (current)
Profile: 0x0008
Profile: 0x0002 (current)
Profile: 0x0010
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
Drive buf size : 1951488 = 1905 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data    92 MB
Total size:      106 MB (10:34.48) = 47586 sectors
Lout start:      107 MB (10:36/36) = 47586 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 6
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type C, low Beta category (C-) (6)
  ATIP start of lead in:  -11231 (97:32/19)
  ATIP start of lead out: 359847 (79:59/72)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 27
Manufacturer: Prodisc Technology Inc.
Blocks total: 359847 Blocks current: 359847 Blocks remaining: 312261
Speed set to 1410 KB/s
Starting to write CD/DVD at speed   8.0 in real TAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
Performing OPC...
cdrecord: Success. send opc: scsi sendcmd: no error
CDB:  54 01 00 00 00 00 00 00 00 00
status: 0x4 (CONDITION MET/GOOD)
cmd finished after 60.730s timeout 60s
cdrecord: OPC failed.
Writing  time:   60.742s
cdrecord: fifo had 64 puts and 0 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.


Expected results:

First I wonder why it is saying it is wrinting in 8x mode when I
specify 2x.  Next I don't expect it ti fail this often.  Its a fairly
new cdrw.

Additional info:
a clip from dmesg if this helps?

ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:07.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci0000:00:07.1
    ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:pio
hda: WDC WD300BB-32AUA1, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: COMBO-52X16C, ATAPI CD/DVD-ROM drive
hdd: IOMEGA ZIP 100 ATAPI, ATAPI FLOPPY drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 58633344 sectors (30020 MB) w/2048KiB Cache, CHS=58168/16/63,
UDMA(100)
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 >
hdc: ATAPI 52X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Comment 1 Harald Hoyer 2004-12-07 11:34:57 EST
cdrecord: OPC failed.

Did you try recent update kernels and update cdrecord?
Comment 2 Joe Acosta 2005-09-08 00:26:23 EDT
uname -a:
Linux Lserver.org 2.6.12-1.1447_FC4 #1 Fri Aug 26 20:29:51 EDT 2005 i686 athlon
i386 GNU/Linux

output of cdrecord (cdrecord-2.01.1-9):
Linux sg driver version: 3.5.27
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: '0,5,0'
scsibus: 0 target: 5 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 4
Response Format: 2
Capabilities   : SYNC
Vendor_info    : 'HP      '
Identifikation : 'CD-Writer+ 9200 '
Revision       : '1.0c'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Drive buf size : 4183808 = 4085 KB
Drive DMA Speed: 8135 kB/s 46x CD 5x DVD
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Reference speed: 2
  Is not unrestricted
  Is erasable
  ATIP start of lead in:  -11635 (97:26/65)
  ATIP start of lead out: 337350 (75:00/00)
  1T speed low:  0 (reserved val  0) 1T speed high:  4
  2T speed low:  8 2T speed high:  0 (reserved val 10)
  power mult factor: 4 6
  recommended erase/write power: 3
  A1 values: 02 4C B0
  A2 values: 4A C8 06
Disk type:    Phase change
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Speed set to 706 KB/s
Starting to write CD/DVD at speed   4.0 in real BLANK mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Performing OPC...
Blanking entire disk
cdrecord: Input/output error. blank unit: scsi sendcmd: no error
CDB:  A1 00 00 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 02 00 00 00 00 12 00 00 00 00 04 08 00 80
Sense Key: 0x2 Not Ready, Segment 0
Sense Code: 0x04 Qual 0x08 (logical unit not ready, long write in progress) Fru 0x0
Sense flags: Blk 0 (not valid) operation 0% done
cmd finished after 1010.052s timeout 9600s
cdrecord: Cannot blank disk, aborting.
Comment 3 Joe Acosta 2005-09-08 00:28:10 EDT
FYI: I'm now running FC 4 and still have this problem.

Comment 4 Russell McOrmond 2005-09-21 11:52:22 EDT
I'm not sure if this should be a new bug or not.  Please let me know if I should
move this elsewhere.

I recently upgraded from FC1 to FC4.  CDRECORD worked fine under FC1, but now fails.

I get new error messages in dmesg that were never there before:

[russell@amadpur ~]>dmesg | grep hde:
    ide2: BM-DMA at 0xc400-0xc407, BIOS settings: hde:pio, hdf:pio
hde: 8X4X32, ATAPI CD/DVD-ROM drive
hde: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
hde: write_intr: bad interrupt reason 1
hde: status error: status=0x58 { DriveReady SeekComplete DataRequest }
hde: drive not ready for command


A dummy test with cdrecord shows (I don't want to ruin more blanks...). In FC1
it was dev=0,1,0 , and now I have to specify dev=ATAPI:2,0,0  . If I do the
-scanbus it shows the drive at 2,0,0 but the 'sg' interface doesn't seem to work
any more (whether I load ide_scsi module or not).

[root@amadpur russell]# cdrecord -v dev=ATAPI:2,0,0 -eject -dummy -data  
/filesD/torrent/torrents/TheOpenCD-3.0.iso
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: 'ATAPI:2,0,0'
devname: 'ATAPI'
scsibus: 2 target: 0 lun: 0
Use of ATA is preferred over ATAPI.
Warning: Using ATA Packet interface.
Warning: The related Linux kernel interface code seems to be unmaintained.
Warning: There is absolutely NO DMA, operations thus are slow.
Using libscg version 'schily-0.8'.
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'ATAPI   '
Identifikation : 'CD-R/RW 8X4X32  '
Revision       : '5.AX'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO
Supported modes: TAO PACKET SAO RAW/R16
Drive buf size : 1634304 = 1596 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data   596 MB
Total size:      684 MB (67:49.10) = 305183 sectors
Lout start:      684 MB (67:51/08) = 305183 sectors
Current Secsize: 2048
  ATIP start of lead in:  -11634 (97:26/66)
  ATIP start of lead out: 359846 (79:59/71)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Blocks total: 359846 Blocks current: 359846 Blocks remaining: 54663
Speed set to 1434 KB/s
Starting to write CD/DVD at speed   8.0 in dummy TAO mode for single session.
Last chance to quit, starting dummy write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
Starting new track at sector: 0
Track 01:   31 of  596 MB written (fifo 100%) [buf  99%]   8.1x.cdrecord:
Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 3E 5D 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 38 00 00 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x38 Qual 0x00 (event status notification) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.000s timeout 40s

write track data: error after 32696320 bytes
cdrecord: A write error occured.
cdrecord: Please properly read the error message above.
Writing  time:   34.143s
Average write speed 119.2x.
Min drive buffer fill was 99%
Total of 1 possible drive buffer underruns predicted.
Fixating...
WARNING: Some drives don't like fixation in dummy mode.
Fixating time:   41.173s
cdrecord: fifo had 579 puts and 516 gets.
cdrecord: fifo was 0 times empty and 493 times full, min fill was 93%.
Comment 5 Joe Acosta 2005-09-21 13:39:37 EDT
I've since upgraded the firmware in my ide cdrw and moved the device to a
FreeBSD 5.2 box and it works flawlessly.

If possible try seeing if there is a new firmware for the drive and upgrade the
firmware.  You may need a windows machine to do the firmware update.  I was
lucky, mine was updatable via dos.
Comment 6 Harald Hoyer 2005-09-22 03:05:52 EDT
Russell McOrmond, please use dev=/dev/hde and do not use ide-scsi emulation in
the kernel parameter. If the problems persists, then file a bug for the
component "kernel".
Comment 7 Joe Acosta 2005-09-24 14:04:56 EDT
I'm not using ide-scsi, I have a scsi device.  Its real scsi. It used to work,
and not it does not.
Comment 8 Joe Acosta 2005-10-08 20:16:23 EDT
Oh, I was not using ide-scsi when I filed this either.  

It may be a firmware upgrade is needed on the device though.  Not sure how Linux
handles that one.

I am wondering if the problem is really in cdrecord itself and not the kernel as
I have similar problems with my SCSI drive.  I'd love to know how to update the
firmware in my HP 9200 SCSI drive.   
Comment 9 Joe Acosta 2005-10-08 20:44:31 EDT
Okay just ran yup update and the version of cdrecord that is installed is now
working, or seems to be working fine.  I've blanked a cd rw twice, and burned to
it once and am blanking it again.

Seems to be okay now.  

cdrecord-2.01.1-9.0.FC4.1


Linux sg driver version: 3.5.27
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
cdrecord: No write mode specified.
cdrecord: Asuming -tao mode.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
cdrecord: Continuing in 5 seconds...
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: '0,5,0'
scsibus: 0 target: 5 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c        1.83 04/05/20 Copyright
1997 J. Schilling').
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 4
Response Format: 2
Capabilities   : SYNC
Vendor_info    : 'HP      '
Identifikation : 'CD-Writer+ 9200 '
Revision       : '1.0c'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
Drive buf size : 4183808 = 4085 KB
Drive DMA Speed: 8135 kB/s 46x CD 5x DVD
FIFO size      : 4194304 = 4096 KB
Track 01: data   549 MB
Total size:      631 MB (62:34.68) = 281601 sectors
Lout start:      631 MB (62:36/51) = 281601 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Reference speed: 2
  Is not unrestricted
  Is erasable
  ATIP start of lead in:  -11635 (97:26/65)
  ATIP start of lead out: 337350 (75:00/00)
  1T speed low:  0 (reserved val  0) 1T speed high:  4
  2T speed low:  8 2T speed high:  0 (reserved val 10)
  power mult factor: 4 6
  recommended erase/write power: 3
  A1 values: 02 4C B0
  A2 values: 4A C8 06
Disk type:    Phase change
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Blocks total: 337350 Blocks current: 337350 Blocks remaining: 55749
Speed set to 706 KB/s
Starting to write CD/DVD at speed   4.0 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
Performing OPC...
Starting new track at sector: 0
Track 01:  549 of  549 MB written (fifo 100%) [buf  99%]   4.0x.
Track 01: Total bytes read/written: 576714752/576714752 (281599 sectors).
Writing  time:  945.074s
Average write speed   4.0x.
Min drive buffer fill was 99%
Fixating...
Fixating time:   62.207s
cdrecord: fifo had 9084 puts and 9084 gets.
cdrecord: fifo was 0 times empty and 8975 times full, min fill was 95%.
Comment 10 R.S. Tse 2005-10-13 09:41:43 EDT
(In reply to comment #4)
> I'm not sure if this should be a new bug or not.  Please let me know if I should
> move this elsewhere.
> 
> I recently upgraded from FC1 to FC4.  CDRECORD worked fine under FC1, but now
fails.
> 
> I get new error messages in dmesg that were never there before:
> 
> [russell@amadpur ~]>dmesg | grep hde:
>     ide2: BM-DMA at 0xc400-0xc407, BIOS settings: hde:pio, hdf:pio
> hde: 8X4X32, ATAPI CD/DVD-ROM drive
> hde: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: cdrom_pc_intr: The drive appears confused (ireason = 0x01)
> hde: write_intr: bad interrupt reason 1
> hde: status error: status=0x58 { DriveReady SeekComplete DataRequest }
> hde: drive not ready for command
> 
> 
> A dummy test with cdrecord shows (I don't want to ruin more blanks...). In FC1
> it was dev=0,1,0 , and now I have to specify dev=ATAPI:2,0,0  . If I do the
> -scanbus it shows the drive at 2,0,0 but the 'sg' interface doesn't seem to work
> any more (whether I load ide_scsi module or not).
> 
> [root@amadpur russell]# cdrecord -v dev=ATAPI:2,0,0 -eject -dummy -data  
> /filesD/torrent/torrents/TheOpenCD-3.0.iso
> cdrecord: No write mode specified.
> cdrecord: Asuming -tao mode.
> cdrecord: Future versions of cdrecord may have different drive dependent defaults.
> cdrecord: Continuing in 5 seconds...
> Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg
Schilling
> Note: This version is an unofficial (modified) version with DVD support
> Note: and therefore may have bugs that are not present in the original.
> Note: Please send bug reports or support requests to
> http://bugzilla.redhat.com/bugzilla
> Note: The author of cdrecord should not be bothered with problems in this version.
> TOC Type: 1 = CD-ROM
> scsidev: 'ATAPI:2,0,0'
> devname: 'ATAPI'
> scsibus: 2 target: 0 lun: 0
> Use of ATA is preferred over ATAPI.
> Warning: Using ATA Packet interface.
> Warning: The related Linux kernel interface code seems to be unmaintained.
> Warning: There is absolutely NO DMA, operations thus are slow.
> Using libscg version 'schily-0.8'.
> SCSI buffer size: 64512
> atapi: 1
> Device type    : Removable CD-ROM
> Version        : 0
> Response Format: 1
> Vendor_info    : 'ATAPI   '
> Identifikation : 'CD-R/RW 8X4X32  '
> Revision       : '5.AX'
> Device seems to be: Generic mmc CD-RW.
> Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
> Driver flags   : MMC SWABAUDIO
> Supported modes: TAO PACKET SAO RAW/R16
> Drive buf size : 1634304 = 1596 KB
> FIFO size      : 4194304 = 4096 KB
> Track 01: data   596 MB
> Total size:      684 MB (67:49.10) = 305183 sectors
> Lout start:      684 MB (67:51/08) = 305183 sectors
> Current Secsize: 2048
>   ATIP start of lead in:  -11634 (97:26/66)
>   ATIP start of lead out: 359846 (79:59/71)
> Disk type:    Short strategy type (Phthalocyanine or similar)
> Manuf. index: 3
> Manufacturer: CMC Magnetics Corporation
> Blocks total: 359846 Blocks current: 359846 Blocks remaining: 54663
> Speed set to 1434 KB/s
> Starting to write CD/DVD at speed   8.0 in dummy TAO mode for single session.
> Last chance to quit, starting dummy write    0 seconds. Operation starts.
> Waiting for reader process to fill input buffer ... input buffer ready.
> trackno=0
> Starting new track at sector: 0
> Track 01:   31 of  596 MB written (fifo 100%) [buf  99%]   8.1x.cdrecord:
> Input/output error. write_g1: scsi sendcmd: no error
> CDB:  2A 00 00 00 3E 5D 00 00 1F 00
> status: 0x2 (CHECK CONDITION)
> Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 38 00 00 00 00 00
> Sense Key: 0x5 Illegal Request, Segment 0
> Sense Code: 0x38 Qual 0x00 (event status notification) Fru 0x0
> Sense flags: Blk 0 (not valid)
> cmd finished after 0.000s timeout 40s
> 
> write track data: error after 32696320 bytes
> cdrecord: A write error occured.
> cdrecord: Please properly read the error message above.
> Writing  time:   34.143s
> Average write speed 119.2x.
> Min drive buffer fill was 99%
> Total of 1 possible drive buffer underruns predicted.
> Fixating...
> WARNING: Some drives don't like fixation in dummy mode.
> Fixating time:   41.173s
> cdrecord: fifo had 579 puts and 516 gets.
> cdrecord: fifo was 0 times empty and 493 times full, min fill was 93%.
> 

(In reply to comment #0)
> Description of problem: cdrecord fails to burn a cd but it says it
> succeded and then says it failed to burn
> 
> Performing OPC...
> cdrecord: Success. send opc: scsi sendcmd: no error
> CDB:  54 01 00 00 00 00 00 00 00 00
> status: 0x4 (CONDITION MET/GOOD)
> cmd finished after 60.730s timeout 60s
> cdrecord: OPC failed.
> Writing  time:   60.742s
> cdrecord: fifo had 64 puts and 0 gets.
> cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.
> 
> 
> Version-Release number of selected component (if applicable):
> 
> cdrecord-2.01.1-0.FC2.1
> [root@Lserver root]# cdrecord --version
> Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
> Jörg Schilling
> Note: This version is an unofficial (modified) version with DVD support
> Note: and therefore may have bugs that are not present in the original.
> Note: Please send bug reports or support requests to
> http://bugzilla.redhat.com/bugzilla
> Note: The author of cdrecord should not be bothered with problems in
> this version.
> 
> 
> How reproducible:  50 / 50 I try to burn a cdrom and 50% of the time
> if fails.  Usually the cd-r is hozed and cannot be used anymore.
> 
> 
> Steps to Reproduce:
> 1. make an iso with mkisofs
> 2. run cdrecord -v speed=2 dev=ATA:1,0,0 <your iso file goes here>
> 3. it fails
>   
> Actual results:
> cdrecord: No write mode specified.
> cdrecord: Asuming -tao mode.
> cdrecord: Future versions of cdrecord may have different drive
> dependent defaults.
> cdrecord: Continuing in 5 seconds...
> Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
> Jörg Schilling
> Note: This version is an unofficial (modified) version with DVD support
> Note: and therefore may have bugs that are not present in the original.
> Note: Please send bug reports or support requests to
> http://bugzilla.redhat.com/bugzilla
> Note: The author of cdrecord should not be bothered with problems in
> this version.
> TOC Type: 1 = CD-ROM
> scsidev: 'ATA:1,0,0'
> devname: 'ATA'
> scsibus: 1 target: 0 lun: 0
> Linux sg driver version: 3.5.27
> Using libscg version 'schily-0.8'.
> cdrecord: Warning: using inofficial libscg transport code version
> (schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
> 1.83 04/05/20 Copyright 1997 J. Schilling').
> SCSI buffer size: 64512
> atapi: -1
> Device type    : Removable CD-ROM
> Version        : 0
> Response Format: 1
> Vendor_info    : '        '
> Identifikation : 'COMBO-52X16C    '
> Revision       : '2.00'
> Device seems to be: Generic mmc2 DVD-ROM.
> Current: 0x0009
> Profile: 0x000A
> Profile: 0x0009 (current)
> Profile: 0x0008
> Profile: 0x0002 (current)
> Profile: 0x0010
> Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
> Driver flags   : MMC-3 SWABAUDIO BURNFREE
> Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
> RAW/R96R
> Drive buf size : 1951488 = 1905 KB
> FIFO size      : 4194304 = 4096 KB
> Track 01: data    92 MB
> Total size:      106 MB (10:34.48) = 47586 sectors
> Lout start:      107 MB (10:36/36) = 47586 sectors
> Current Secsize: 2048
> ATIP info from disk:
>   Indicated writing power: 6
>   Is not unrestricted
>   Is not erasable
>   Disk sub type: Medium Type C, low Beta category (C-) (6)
>   ATIP start of lead in:  -11231 (97:32/19)
>   ATIP start of lead out: 359847 (79:59/72)
> Disk type:    Short strategy type (Phthalocyanine or similar)
> Manuf. index: 27
> Manufacturer: Prodisc Technology Inc.
> Blocks total: 359847 Blocks current: 359847 Blocks remaining: 312261
> Speed set to 1410 KB/s
> Starting to write CD/DVD at speed   8.0 in real TAO mode for single
> session.
> Last chance to quit, starting real write    0 seconds. Operation starts.
> Waiting for reader process to fill input buffer ... input buffer ready.
> trackno=0
> BURN-Free is OFF.
> Performing OPC...
> cdrecord: Success. send opc: scsi sendcmd: no error
> CDB:  54 01 00 00 00 00 00 00 00 00
> status: 0x4 (CONDITION MET/GOOD)
> cmd finished after 60.730s timeout 60s
> cdrecord: OPC failed.
> Writing  time:   60.742s
> cdrecord: fifo had 64 puts and 0 gets.
> cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.
> 
> 
> Expected results:
> 
> First I wonder why it is saying it is wrinting in 8x mode when I
> specify 2x.  Next I don't expect it ti fail this often.  Its a fairly
> new cdrw.
> 
> Additional info:
> a clip from dmesg if this helps?
> 
> ide: Assuming 33MHz system bus speed for PIO modes; override with
> idebus=xx
> VP_IDE: IDE controller at PCI slot 0000:00:07.1
> VP_IDE: chipset revision 6
> VP_IDE: not 100% native mode: will probe irqs later
> VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci0000:00:07.1
>     ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hda:DMA, hdb:pio
>     ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdc:DMA, hdd:pio
> hda: WDC WD300BB-32AUA1, ATA DISK drive
> ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> hdc: COMBO-52X16C, ATAPI CD/DVD-ROM drive
> hdd: IOMEGA ZIP 100 ATAPI, ATAPI FLOPPY drive
> ide1 at 0x170-0x177,0x376 on irq 15
> hda: max request size: 128KiB
> hda: 58633344 sectors (30020 MB) w/2048KiB Cache, CHS=58168/16/63,
> UDMA(100)
>  hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 >
> hdc: ATAPI 52X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)

The author in his website says that cdrecord 2.x works well with kernel 2.4 but
needs real root login with kernel 2.6.  I tried that and received no error
message; the writing process took much shorter than usual.  However, nothing
could be read from the written DVD.
Comment 11 Joe Acosta 2005-10-13 23:21:30 EDT
I always buen my CDROMS as root.  There is / was a bug in cdrecord that ships
with fedora, and the latest update seems to have fixed it.  

The cdrecord web site also says don't contact him about problems in fc / rh
because they ship an unoffical version of the software that may not work.  
Comment 12 John Thacker 2006-04-21 13:10:17 EDT
Reporter said this was fixed in an update.  Closing

Note You need to log in before you can comment on or make changes to this bug.