Bug 13664 - OpenLDAP Package Missing slapd
OpenLDAP Package Missing slapd
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-10 17:07 EDT by Thornton Prime
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-10 18:11:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thornton Prime 2000-07-10 17:07:20 EDT
The man pages are there, as is slurpd, but all traces of the slurpd binary
and slurpd configuration files are gone.


It would be a good idea to split the package into three

openldap-common
openldap-client
openldap-server
Comment 1 Thornton Prime 2000-07-10 18:11:52 EDT
I see there is a problem with the build.

gcc -O2 -m486 -fno-strength-reduce -g -D_REENTRANT -I../../include
-I../../include -I/usr/include/db3 -I/usr/kerberos/include -DHAVE_CONFIG_H
-L/usr/src/redhat/BUILD/openldap-1.2.11/libraries -L/usr/kerberos/lib -o slapd
main.o daemon.o connection.o search.o filter.o add.o charray.o attr.o entry.o
config.o backend.o result.o operation.o dn.o compare.o modify.o delete.o
modrdn.o ch_malloc.o value.o ava.o bind.o unbind.o abandon.o filterentry.o
phonetic.o acl.o str2filter.o aclparse.o init.o repl.o lock.o user.o
suffixalias.o schema.o schemaparse.o monitor.o configinfo.o version.o
libbackends.a -lavl -lldbm -lldif -lldap -llber -llthread -llutil -ldb1 -lcrypt
-lnsl -lresolv -pthread -lwrap
/usr/src/redhat/BUILD/openldap-1.2.11/libraries/libldbm.a(ldbm.o): In function
`ldbm_open':
/home/src/redhat/BUILD/openldap-1.2.11/libraries/libldbm/ldbm.c:177: undefined
reference to `__db185_open'
Comment 2 Nalin Dahyabhai 2000-07-10 18:45:44 EDT
Aargh!  Bitten by more dbx/dbx-devel weirdness.  That's it.  I'm configuring
OpenLDAP to use gdbm from now on....  Since this is a pretty annoying one,
packages will show up in http://people.redhat.com/nalin/ soon.

Note You need to log in before you can comment on or make changes to this bug.