This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 136729 - counters underflow.
counters underflow.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mtr (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-21 18:52 EDT by Dave Jones
Modified: 2015-01-04 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 06:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2004-10-21 18:52:41 EDT
Keys:  D - Display mode    R - Restart statistics    Q - Quit
        Packets               Pings
Hostname                             %Loss  Rcv  Snt  Last Best  Avg 
Worst
 1. 192.168.217.1                     0%    0    0  -501530    0    0   0
 2. 12.46.108.97                      0%    0    0  -501576    0    0   0
 3. 12.46.111.243                     0%    0    0  -501629    0    0   0


Why are those counters signed numbers anyway ?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Phil Knirsch 2004-10-22 10:02:40 EDT
Can you tell me how to reproduce it?

And i agree, signed counters don't make much sense here, but an
overflow still would probably happen, just no negative numbers then...

Read ya, Phil
Comment 2 Dave Jones 2004-10-22 14:09:42 EDT
I saw it happen on a very congested hotel wireless network.
Haven't managed to reproduce it under other conditions.
Comment 3 Phil Knirsch 2005-09-05 08:36:48 EDT
I've tried to reproduce it here but without any luck.

If you happen to find a reproducible case please let me know and i'll give it
another shot.

Read ya, Phil
Comment 4 Dave Jones 2005-09-12 03:43:39 EDT
I guess I've not been on a similarly crappy network since :-)
Might be worth bringing this up upstream, as it involves changing prototypes of
various functions etc, not just a simple %d -> %ud conversion.
Comment 5 Marcela Mašláňová 2006-06-07 06:05:38 EDT
Fixed (Bugzilla #136729)

Note You need to log in before you can comment on or make changes to this bug.