Bug 136754 - update of openoffice.org impossible due to redhat-artwork 64/32 bit issues
update of openoffice.org impossible due to redhat-artwork 64/32 bit issues
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
: 136776 136823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 01:52 EDT by Michael J. Cohen
Modified: 2007-11-30 17:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 18:42:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum.conf (968 bytes, text/plain)
2004-11-01 10:21 EST, Sebastian Paul Avarvarei
no flags Details
sysconfig/rhn/sources (1.91 KB, text/plain)
2004-11-01 10:23 EST, Sebastian Paul Avarvarei
no flags Details
Output of up2date openoffice.org showing entire session and problem (9.72 KB, text/plain)
2004-11-07 23:35 EST, David G Sparks
no flags Details

  None (edit)
Description Michael J. Cohen 2004-10-22 01:52:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
during a yum update earlier today, openoffice (32-bit application) was
unable to find the 32-bit libbluecurve.so.  later this evening
redhat-artwork-0.96-1.i386 was added, but now it conflicts with
redhat-artwork-0.96-1.x86_64:

Running test transaction:
Errors reported doing trial run
file /usr/share/xmms/Skins/Bluecurve-xmms.zip from install of
redhat-artwork-0.96-1 conflicts with file from package
redhat-artwork-0.96-1


Version-Release number of selected component (if applicable):
redhat-artwork 0.96-1.x86_64, redhat-artwork 0.96-1.i386

How reproducible:
Always

Steps to Reproduce:
1. install openoffice.org from CD
2. yum update

Actual Results:  Running test transaction:
Errors reported doing trial run
file /usr/share/xmms/Skins/Bluecurve-xmms.zip from install of
redhat-artwork-0.96-1 conflicts with file from package
redhat-artwork-0.96-1

Expected Results:  successful yum update.

Additional info:
Comment 1 Alexander Larsson 2004-10-22 03:26:38 EDT
Dan, did something change here? The FC2 redhat-artwork has a
multilib-conflict which has been fixed later. Do i need to release an
update for it?
Comment 2 Dan Williams 2004-10-22 08:10:44 EDT
Could you do that?  The new OOo links to GTK and uses the GTK
filechooser, this was to fix another bug for x86_64 where GTK would
use the built-in theme rather than Bluecurve on a default install
becuase it couldn't find the 32-bit libbluecurve.so, along with all
the icons and whatnot for that theme.  If you could release a
multi-lib redhat-artwork as an FC2 update, that would be great.
Comment 3 Dan Williams 2004-10-22 09:42:24 EDT
*** Bug 136776 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2004-10-22 11:15:06 EDT
*** Bug 136823 has been marked as a duplicate of this bug. ***
Comment 5 Nick Henriquez 2004-10-26 14:45:56 EDT
From the text before I understand the bug has been fixed in some way.
I still get the same error 26 October. To this date OOo won install
due to conflict. Error messg same as in 1st bugreport, I see no change.
Comment 6 Joe Harrington 2004-10-27 12:57:41 EDT
I'd like to see this bug escalated to security level because this
problem is preventing all automatic nightly yum updates from running
on x86_64, and those updates include security updates xpdf-3.00-3.4
and cups-1.1.20-11.6 (so far).

Those needing a security workaround can do:
yum -y update xpdf cups
...and monitor for more security updates until this is resolved.

--jh--
Comment 7 John Thacker 2004-10-27 18:21:27 EDT
Looks to me like redhat-artwork-0.96-2 fixes the problem, and it's
been released.  Had the problem on a x86-64 machine, now updates.
Comment 8 Sebastian Paul Avarvarei 2004-10-30 05:47:07 EDT
In my case, I have updated to redhat-artwork-0.96-2 and,
unfortunately, the problem with updating OpenOffice still persists.

I also tried to manually upgrade the OpenOffice packages, no luck either:

  >rpm -Uvh openoffice.org-*
  error: Failed dependencies:
  libbluecurve.so is needed by openoffice.org-1.1.2-10.fc2

As Joe Harrington pointed out earlier, this is becoming a security
issue, since it prevents other updates from being performed.

Please let me know if I can provide any further information in order
to help fixing this problem.

Best regards,
Sebastian Paul Avarvarei
Comment 9 Jason Tibbitts 2004-10-30 11:49:15 EDT
Everything is right with the new packages, and if you let yum work out
the dependencies everything will install fine.  If you insist on doing
it manually, make sure you have both i386 and x86_64 versions of
redhat-artwork-0.96-2 installed.  The openoffice packages are built
for i386, so you need the i386 bluecurve.so.
Comment 10 Sebastian Paul Avarvarei 2004-10-30 18:00:37 EDT
Sorry if I have not expressed myself correctly. I don't "insist" on 
doing things manually.




I did let up2date/yum to update redhat-artwork. And then I ran 
up2date again in order to update OpenOffice. But this failed again, 
with the same error I was getting when redhat-artwork-0.96-1 was 
installed.




I provided the output of manually running "rpm -Uvh" just in case it 
would help with anything.




If any other information would be of help, please let me know.




Best regards,


Sebastian Paul Avarvarei


Comment 11 Dan Williams 2004-10-31 09:26:49 EST
Can you do this?

rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n"
redhat-artwork

I personally took an x86-64 system with FC2 and successfully did an
upgrade of OOo.  It _did_ fail before I installed the i386 version of
redhat-artwork-0.96-2 using a manual RPM.  I then updated
openoffice.org using yum.  This really should work, it was flawless
for me.
Comment 12 Joe Harrington 2004-10-31 12:03:10 EST
The new packages worked for me on x86_64.  The only manual updates I
did were xpdf and cups, as above.  My system's nightly yum update took
the OOo updates the night redhat-artwork-0.96-2 got posted.  I have an
"everything" install.

Thanks to those who got on the ball and fixed this!

--jh--
Comment 13 Sebastian Paul Avarvarei 2004-11-01 04:14:21 EST
Yes, what I have in the system is redhat-artwork-0.96-2-x86_64. If I
would manually install the i386 version probably the auto-update of
OpenOffice will work too.

But I don't think this can really be called a solution. The whole
point of using up2date is to be able to automate the updating process.

What I would consider a solution would be to either:
1. Modify the redhat-artwork x86_64 rpm so it provides what OpenOffice
needs.
2. Modify at least the OpenOffice rpm so it will include the i386
version of redhat-artwork in its requirements, so the up2date process
would install it automatically.

Best regards,
Sebastian
Comment 14 Dan Williams 2004-11-01 09:16:57 EST
No, that's not the way it works Sebastian.

You point yum/up2date at repositories of RPMs.  Contained in those
repositories are the RPMS you need.  If they aren't there, it won't
work.  But they _are_ there:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/x86_64/redhat-artwork-0.96-2.i386.rpm

Note that this is the _i386_ RPM but its in the x86_64 repository. 
That's multilib for you.  But if you use yum it _will work_.

You can't just modify OOo to use the x86_64 RPM, because the bits that
OOo needs are 32-bit, and the x86_64 RPM doesn't provide anything
that's 32-bit.  That's why the i386 redhat-artwork RPM is there,
that's what OOo needs.  If you did a fully automatic update pointed at
the right place, you'd have no problems.  You need to install BOTH the
x86_64 and the i386 redhat-artwork RPMs, this is normal.

Stick this in your /etc/yum.conf file, run 'yum update openoffice.org'
and you'll be fine:

[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
retries=20

[base]
name=Fedora Core $releasever - $basearch - Base
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/$releasever/$basearch/

[updates]
name=Fedora Core $releasever - $basearch - Updates
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/core/updates/$releasever/$basearch/
Comment 15 Sebastian Paul Avarvarei 2004-11-01 09:41:21 EST
This still can't be called a solution. The point is quite simple:
redhat-artwork breaks the auto-update for OpenOffice. Any discussion
about manually installing packages or manually running yum is, in my
opinion, pretty much besides the point.

And yes, I was using the standard yum.conf as it was installed by
Fedora, only modified it to point to a mirror.

Anyway, if you don't want to acknowledge this as a bug, that's your
choice. Why should I bother?
Comment 16 Dan Williams 2004-11-01 09:49:31 EST
No, I'm trying to say I don't understand what's different about your
situtation.  The current updates tree is as normal AFAIK, everything
is as it should be.  I don't understand why that's not working for
you.  I'm not saying its not a bug.

Can you paste the output of 'yum update openoffice.org' and the
contents of your yum.conf file?

Thanks!
Dan
Comment 17 Sebastian Paul Avarvarei 2004-11-01 09:53:48 EST
Sorry, too late. I installed redhat-artwork i386 manually to get it
over with, as this already took too much of my time.

But you can reproduce the error yourself quite easily: just install a
new FC2 system and run up2date.
Comment 18 Dan Williams 2004-11-01 10:02:12 EST
Can you paste in your copy of /etc/sysconfig/rhn/sources so I can try
to duplicate then?  Let me repeat that this worked for me with yum,
but I haven't tried up2date, so that may be the issue.
Comment 19 Sebastian Paul Avarvarei 2004-11-01 10:21:28 EST
Created attachment 106015 [details]
yum.conf
Comment 20 Sebastian Paul Avarvarei 2004-11-01 10:23:30 EST
Created attachment 106016 [details]
sysconfig/rhn/sources
Comment 21 Sebastian Paul Avarvarei 2004-11-01 10:25:20 EST
Please find attached the requested config files - I included yum.conf
too, in case it might help with anything.
Comment 22 Dan Williams 2004-11-01 11:24:52 EST
Ok, in your yum.conf file you have a bad URL for the updates-released,
which might be the problem:

baseurl=http://ftp.lug.ro/fedora/linux/core/2/updates/$releasever/$basearch/os/

That URL returns an error since its actually
fedora/linux/core/updates/2 rather than fedora/linux/core/2/updates.
Comment 23 Sebastian Paul Avarvarei 2004-11-01 11:38:43 EST
All other updates (except redhat-artwork and OpenOffice) ran very 
well, so I would doubt that this was indeed the problem.
Comment 24 David G Sparks 2004-11-07 23:35:49 EST
Created attachment 106267 [details]
Output of up2date openoffice.org showing entire session and problem

Reading other comments it sounded like somebody wanted to see an example.
Here's mine, if it can help.

Thanks,

David
Comment 25 Dan Williams 2004-11-08 22:13:21 EST
*** Bug 138410 has been marked as a duplicate of this bug. ***
Comment 26 Dan Williams 2004-11-08 22:19:02 EST
Adrian:  seems to be only up2date that has this issue.  yum deals with
it fine.
Comment 27 Adrian Likins 2004-11-09 15:17:12 EST
sounds like a bug I fixed in 4.3.56, can someone
try it with 4.3.56?
Comment 28 Matthew Miller 2005-04-26 12:38:45 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 29 Todd Warner 2005-09-23 18:42:42 EDT
no response in nearly a year from reporter... closing.

Note You need to log in before you can comment on or make changes to this bug.