Bug 136765 - "Play Test Sound" locks up in KDE
"Play Test Sound" locks up in KDE
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 04:42 EDT by Joel Rittvo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 22:51:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joel Rittvo 2004-10-22 04:42:30 EDT
Description of problem:
Running system-config-soundcard in Gnome correctly detects my
soundcard and allows the "Play test sound" button to play the test
sound and I can then tell the applet that the test worked.  Doing the
same under KDE, the card is again correctly identified, but the applet
locks up after pressing the "Play test sound" button and is unable to
complete.  No sound is played.  Behavior is the same whether I am
logged in as root or as a user. Soundcard is Intel AC'97 based using
snd-intel8x0 module, and it actually works fine for everything except
for this one set-up test in KDE.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Log into a KDE session.
2. Run system-config-soundcard
3. Click on the "Play test sound" button, after card is correctly
detected.
  
Actual results:
No sound plays.  Applet locks up.

Expected results:
Sound should play as it does in a Gnome session, allowing applet to be
completed.

Additional info:
Is this because KDE is using aRts and Gnome uses something else, and
the applet is coded to use only one correctly?
Comment 1 Joel Rittvo 2004-11-15 22:51:57 EST
I am closing this, because it does in fact work, but it takes about 90
seconds to play the test sound on my machine, and I wasn't waiting
that long before.  I guess (again) that it is trying different sound
servers (?) until it hits on one that works, or, that since it is
running as root, it needs to wait until the user account frees up
aRts???  Anyway, maybe there should be some text added that suggests
waiting 2 to 3 minutes before trying to close the window assuming failure.

Note You need to log in before you can comment on or make changes to this bug.