Bug 136789 - Loading fonts fails
Loading fonts fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnucash (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 08:20 EDT by Holger Eilhard
Modified: 2014-03-16 22:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-28 07:28:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Holger Eilhard 2004-10-22 08:20:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
After installing gnucash via yum:
# yum install gnucash
Setting up Install Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3429/3429
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package gnucash.i386 0:1.8.9-2 set to be installed
--> Running transaction check
--> Processing Dependency: libofx.so.0 for package: gnucash
--> Processing Dependency: libopenhbci.so.14 for package: gnucash
--> Processing Dependency: libgwrap-glib.so.1 for package: gnucash
--> Processing Dependency: libgwrap-wct.so.1 for package: gnucash
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libofx.i386 0:0.6.6-2 set to be installed
---> Package openhbci.i386 0:0.9.17-1 set to be installed
---> Package g-wrap.i386 0:1.3.4-7 set to be installed
--> Running transaction check

Dependencies Resolved
Transaction Listing:
  Install: gnucash.i386 0:1.8.9-2

Performing the following to resolve dependencies:
  Install: g-wrap.i386 0:1.3.4-7
  Install: libofx.i386 0:0.6.6-2
  Install: openhbci.i386 0:0.9.17-1
Is this ok [y/N]: y
Downloading Packages:
gnucash-1.8.9-2.i386.rpm  100% |=========================| 6.6 MB    00:01
libofx-0.6.6-2.i386.rpm   100% |=========================| 139 kB    00:00
openhbci-0.9.17-1.i386.rp 100% |=========================| 706 kB    00:00
g-wrap-1.3.4-7.i386.rpm   100% |=========================|  65 kB    00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: g-wrap 100 % done 1/4
Installing: openhbci 100 % done 2/4
Installing: libofx 100 % done 3/4
Installing: gnucash 100 % done 4/4
install-info: Warnung: Kein Info-Verzeichnis-Eintrag in
�/usr/share/info/gnucash-design.info.gz�

Installed: gnucash.i386 0:1.8.9-2
Dependency Installed: g-wrap.i386 0:1.3.4-7 libofx.i386 0:0.6.6-2
openhbci.i386 0:0.9.17-1
Complete!

I get the following errors on gnucash startup:
$ gnucash
Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*


Version-Release number of selected component (if applicable):
gnucash-1.8.9-2

How reproducible:
Always

Steps to Reproduce:
1. start gnucash
2. splash screen shows up
3. gnucash crashes
    

Additional info:
Comment 1 Bill Nottingham 2004-10-22 20:52:15 EDT
What locale are you running in?
Comment 2 Holger Eilhard 2004-10-23 08:41:37 EDT
It's de_DE.UTF-8.
Comment 3 Bill Nottingham 2004-10-25 15:13:23 EDT
Out of curiousity, does it work if you run LANG=de_DE gnucash?
Comment 4 Holger Eilhard 2004-10-25 15:22:57 EDT
Then I get:

$ LANG=de_DE gnucash
The font "-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*" does
not support all the required character sets for the current locale "de_DE"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

The font "-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*" does
not support all the required character sets for the current locale "de_DE"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

The font "-adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*" does
not support all the required character sets for the current locale "de_DE"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

The font "-adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*" does
not support all the required character sets for the current locale "de_DE"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

The font "-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*" does
not support all the required character sets for the current locale "de_DE"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

The font "-adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*" does
not support all the required character sets for the current locale "de_DE"
  (Missing character set "ISO8859-1")
  (Missing character set "ISO8859-1")
Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*
Comment 5 Bill Nottingham 2004-10-25 15:39:54 EDT
I can't reproduce this here. What font packages do you have installed
(rpm -qa | grep font), and what libgnomeprint?
Comment 6 Bill Nottingham 2004-10-25 15:40:12 EDT
Actually, never mind libgnomeprint. :)
Comment 7 Holger Eilhard 2004-10-25 16:00:54 EDT
$ rpm -qa |grep font
tetex-fonts-2.0.2-21
fontconfig-2.2.3-5
ghostscript-fonts-5.50-13
bitmap-fonts-0.3-4
urw-fonts-2.2-6
fontconfig-devel-2.2.3-5
fonts-xorg-base-6.8.1-1
xorg-x11-font-utils-6.8.1-12
bitstream-vera-fonts-1.10-4
chkfontpath-1.10.0-2

$ rpm -qa |grep libgnomeprint
libgnomeprint22-2.8.0-2
libgnomeprint15-0.37-10
libgnomeprintui22-2.8.0-1
Comment 8 Bill Nottingham 2004-10-25 16:17:14 EDT
Did you actually mean to notabug this?

What happens if you install one of fonts-xorg-{75,100}dpi?
Comment 9 Holger Eilhard 2004-10-25 16:27:16 EDT
No, I didn't change that on purpose and actually I currently can't
view the Bug activity? I'm getting this when trying:

        SELECT
            COALESCE(fielddefs.description, chr(bugs_activity.fieldid)),
            fielddefs.name,
            bugs_activity.attach_id,
            TO_CHAR(bugs_activity.bug_when, 'YYYY-MM-DD HH24:MI'), 
                bugs_activity.removed, bugs_activity.added,
                profiles.login_name
        FROM bugs_activity LEFT JOIN attachments
                   ON attachments.attach_id = bugs_activity.attach_id
LEFT JOIN fielddefs ON 
                                     bugs_activity.fieldid =
fielddefs.fieldid,
             profiles
        WHERE bugs_activity.bug_id = 136789 
              AND profiles.userid = bugs_activity.who AND
NOT(COALESCE(attachments.isprivate,0))
        ORDER BY bugs_activity.bug_when: ERROR:  Argument of NOT must
be type boolean, not type integer at globals.pl line 340.

Will try the fonts-xorg tomorrow, because my Notebook is currently out
of "fuel"...
Comment 10 Holger Eilhard 2004-10-26 07:33:15 EDT
I installed fonts-xorg-75dpi-6.8.1-1. Same results:

$ gnucash
Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Warning: gnucash_style_set_register...(): Cannot load font:
-adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-r-normal--*-120-*-*-*-*-*-*

Fatal Error: gnucash_style_set_register...(): Cannot load fallback
font: -adobe-helvetica-medium-o-normal--*-120-*-*-*-*-*-*

I'll try rebuilding it here and see if I can find the error that way.
Comment 11 Holger Eilhard 2004-10-28 07:28:07 EDT
Something in the latest rawhide Updates resolved it. It now starts
without any errors...

Note You need to log in before you can comment on or make changes to this bug.