Bug 13679 - xinetd needs -reuse flag
Summary: xinetd needs -reuse flag
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.1
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-10 23:13 UTC by Mike McHenry
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-10 23:13:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McHenry 2000-07-10 23:13:13 UTC
xinetd needs to be run from the rc scripts with the -reuse flag. Without 
this flag heavily used services may not come back after a soft reload or 
even a hard restart. xinetd's default behavior is to not rebind to ports 
that are in use, this is different that inetd's default behavior and 
should be changed to prevent nasty surprises.

I list this as a severe bug because when it happens NOTHING is logged as 
to why the services are not restarted and it is a very difficult thing to 
troubleshoot without any kind of verbose logging. I have been running 
xinetd for over a year with this flag and have had no adverse side effects 
on my servers.

Just run 

xinetd -reuse

from the rc script instead of just xinetd.

Comment 1 Trond Eivind Glomsrxd 2000-07-10 23:25:09 UTC
Already fixed.


Note You need to log in before you can comment on or make changes to this bug.