Bug 136794 - Setting ETHTOOL_OPTS in bonded interfaces doesn't work
Setting ETHTOOL_OPTS in bonded interfaces doesn't work
Status: CLOSED DUPLICATE of bug 128714
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 09:01 EDT by Simon Matter
Modified: 2014-03-16 22:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Simon Matter 2004-10-22 09:01:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Setting ETHTOOL_OPTS in bonded interfaces doesn't work. Neither
setting it in ifcfg-bond0 nor in ifcfg-ethX works.

Version-Release number of selected component (if applicable):
initscripts-7.31.16.EL-1

How reproducible:
Always

Steps to Reproduce:
1. Add a ETHTOOL_OPTS="someting" line to ifcfg-ethX
2. ifup bond0
3. check with ethtool -s ethX
    

Actual Results:  The interface hasn't been configured with the
ETHTOOL_OPTS parameters.

Expected Results:  The interface should have been configured with the
ETHTOOL_OPTS parameters.

Additional info:

This works in a standalone interface definition ifcfg-ethX without the
bonding. Looks like seomthing is missing in /sbin/ifup.
Comment 1 Simon Matter 2004-10-22 09:02:37 EDT
Sorry, step 3 should be ethtool ethX
Comment 2 Bill Nottingham 2004-10-23 00:18:29 EDT

*** This bug has been marked as a duplicate of 128714 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:06:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.