Bug 136795 - hal does not see coldplugged 16-bit PCMCIA cards
hal does not see coldplugged 16-bit PCMCIA cards
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-10-22 09:06 EDT by Brian G. Anderson
Modified: 2015-01-04 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.4.0-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-26 16:14:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
portion of /var/log/messages (2.51 KB, text/plain)
2004-10-22 10:12 EDT, Brian G. Anderson
no flags Details

  None (edit)
Description Brian G. Anderson 2004-10-22 09:06:47 EDT
Description of problem:
I have a laptop with an internal wired ethernet PCI card and an
internal intersil/PRSIM wirelss PC card.  When I boot both cards are
enabled instead of just the wired ethernet.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start computer
2. login
Actual results:
The wired and the wirelss connection are both active.  I have two
network status applets on my panel (one for each) and both are active.

Expected results:
Only the wired card should be active.  Only when I unplug the wired
card should I have an active wireless.

Also If I start with the wired connection disconnected, then plug it
in later, the wired connection is not taken down.

Additional info:

When I run lshal, the wired card appears, but not the wireless.  The
wireless card uses orinoco drivers.

I can shut the wireless interface down using ifdown eth1, but the
routing table is not properly reconfigured by Network manager.  The
quickest way
Comment 1 Brian G. Anderson 2004-10-22 09:09:15 EDT
sorry, I must have hit submit too fast.

To complete my sentence:  The quickest way to restore the wired
interface is to ifdown eth0 followed by ifup eth0
Comment 2 Dan Williams 2004-10-22 09:32:17 EDT
Hmm, this is a hal bug if hal can't see your card.  NM uses hal to get
a list of cards to control.  So, if it can see your wired ethernet but
not the wireless, it probably doesn't know the wireless card exists.

Note that this is probably a PCMCIA card, right?  hal cannot currently
detect PCMCIA cards that are not hotplugged, this is slowly being
fixed (its really a kernel bug, not a hal bug, but the kernel isn't
likely to be fixed that fast).
Comment 3 Brian G. Anderson 2004-10-22 10:12:28 EDT
Created attachment 105646 [details]
portion of /var/log/messages
Comment 4 Brian G. Anderson 2004-10-22 10:13:46 EDT
Yes this is a PCMCIA card.  I tried 'cardctl eject 2; cardctl insert
2' and it does appear in lshal now.  However, I have the wireless
disabled on boot.  Why was it activated and if NetworkManager didn't
do it who did?  Before I activated Network manager the wireless
wouldn't start.

Also, it is a bit confusing that the newtwork monitor applet doesn't
show any difference between the wireless interface when it has no IP
and when it does:  the applet appears to show it up.

However, and this may be the topic for a new bug,  the wireless link
won't stay up.  If I disconnect the wired cable now, tt takes about 45
seconds to try and get an IP address and after it gets one, 30 seconds
later it drops it.  I get a bunch of log messages from network
manager.  I've added an attachement
Comment 5 David Zeuthen 2004-10-22 13:59:13 EDT
We should get these patches for sysfs support in the PCMCIA layer into
the FC3 kernel.


These patches have been in -mm for quite some time and is, IIRC,
scheduled for inclusion in mainline 2.6.10. Things like HAL and
NetworkManager need these so they don't have to copy whole chunks of
pcmcia-cs just to find the 16-bit PCMCIA devices that the kernel
should know about.
Comment 6 David Zeuthen 2004-10-26 16:14:41 EDT
OK, so, I took Dan's patch for importing big chunks of pcmcia-cs into
hal so these patches to the kernel are not needed anymore (though I'm
hoping it will get merged into mainline so in the future hal doesn't
need to contain all that pcmcia-cs code). Fix is in hal-0.4.0-8
available from here


and it will hopefully get into FC3.

Note You need to log in before you can comment on or make changes to this bug.