Bug 136818 - Comboboxes have extra space when they are opened beside the edge of the screen
Summary: Comboboxes have extra space when they are opened beside the edge of the screen
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk+   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-22 14:48 UTC by Takayuki Ogawa
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 13:11:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot (90.62 KB, text/plain)
2004-10-22 14:49 UTC, Takayuki Ogawa
no flags Details

Description Takayuki Ogawa 2004-10-22 14:48:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
When I use applications such as OpenOffice.org, gedit and Firefox,
their comboboxes show extra space above their candidates.
This bug appears only when their candidates cannot display at once and
the option list become slidable.

Version-Release number of selected component (if applicable):
gtk+-1.2.10-33

How reproducible:
Always

Steps to Reproduce:
1. Start OOo Writer.
2. Open file selection dialog.
3. Move the dialog beside the bottom edge of the screen.
4. Open the combobox to choose the kind of files.


Actual Results:  The combobox has extra space above the candidate list.

Expected Results:  The extra space disappears.

Additional info:

I'm using almost default theme.
GTK's packages installed on my computer are as below.
[takayuki@coffee ~]$ rpm -qa | grep gtk | sort
authconfig-gtk-4.6.5-2
gnome-python2-gtkhtml2-2.6.0-3
gtk+-1.2.10-33
gtk-doc-1.2-2
gtk-engines-0.12-5
gtk2-2.4.13-2
gtk2-devel-2.4.13-2
gtk2-engines-2.2.0-6
gtkhtml2-2.6.2-1
gtkhtml3-3.3.2-3
gtksourceview-1.1.0-3
gtkspell-2.0.7-2
iiimf-gtk-12.1-2
pygtk2-2.3.96-2
pygtk2-2.4.0-1
pygtk2-devel-2.3.96-2
pygtk2-devel-2.4.0-1
pygtk2-libglade-2.3.96-2
pygtk2-libglade-2.4.0-1
usermode-gtk-1.74-1

Comment 1 Takayuki Ogawa 2004-10-22 14:49:10 UTC
Created attachment 105652 [details]
Screen Shot

Comment 2 Matthias Clasen 2004-10-25 13:11:53 UTC
This not a bug, but rather a feature to make the currenly selected
item come up near to the mouse pointer. There is an upstream bug regarding
an improved implementation of this feature
http://bugzilla.gnome.org/show_bug.cgi?id=129463


Note You need to log in before you can comment on or make changes to this bug.