Bug 136854 - ambiguous return of ECHILD in AS2.1 for ypserv [IT 52242]
ambiguous return of ECHILD in AS2.1 for ypserv [IT 52242]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: ypserv (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
Jay Turner
:
Depends On:
Blocks: 143573
  Show dependency treegraph
 
Reported: 2004-10-22 14:41 EDT by Neil Horman
Modified: 2015-01-07 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2006-0203
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 09:21:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport of RHEL3 patch to fix echild death in ypserv (399 bytes, patch)
2004-10-22 14:48 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2004-10-22 14:41:47 EDT
Description of problem:
ypserve occasionally dies with the message:
ypserv[1072]svc_run - poll failed: no child processes

Version-Release number of selected component (if applicable):


How reproducible:
sometimes

Steps to Reproduce:
unknown at present
  
Actual results:
ypserve should not die

Expected results:
ypserve should run

Additional info:
This appears to have been fixed in future versions of ypserv by simply
ignorign the ECHILD result.
Comment 1 Neil Horman 2004-10-22 14:48:36 EDT
Created attachment 105668 [details]
backport of RHEL3 patch to fix echild death in ypserv

This is a backport of the ypserv patch in RHEL3 to prevent this error
Comment 2 Chris Feist 2004-10-22 18:43:32 EDT
The patched package has been added to the dist-2.1AS-errata-candidate
collection.

The new package name is - ypserv-2.8-9.21.i386.rpm
Comment 3 Neil Horman 2004-10-22 19:45:20 EDT
beautiful.  Thanks!
Comment 4 Neil Horman 2005-03-03 13:08:50 EST
Since this is checked in, should it be in modified state?
Comment 5 Chris Feist 2005-03-03 13:44:26 EST
Yes, I didn't assign to myself when I fixed it.  Moving to modified now.
Comment 17 Red Hat Bugzilla 2006-03-21 09:21:45 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0203.html

Note You need to log in before you can comment on or make changes to this bug.