Bug 136854 - ambiguous return of ECHILD in AS2.1 for ypserv [IT 52242]
Summary: ambiguous return of ECHILD in AS2.1 for ypserv [IT 52242]
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: ypserv (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Chris Feist
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 143573
TreeView+ depends on / blocked
 
Reported: 2004-10-22 18:41 UTC by Neil Horman
Modified: 2018-10-19 19:02 UTC (History)
4 users (show)

Fixed In Version: RHBA-2006-0203
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-21 14:21:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backport of RHEL3 patch to fix echild death in ypserv (399 bytes, patch)
2004-10-22 18:48 UTC, Neil Horman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0203 normal SHIPPED_LIVE ypserv bug fix update 2006-03-21 05:00:00 UTC

Description Neil Horman 2004-10-22 18:41:47 UTC
Description of problem:
ypserve occasionally dies with the message:
ypserv[1072]svc_run - poll failed: no child processes

Version-Release number of selected component (if applicable):


How reproducible:
sometimes

Steps to Reproduce:
unknown at present
  
Actual results:
ypserve should not die

Expected results:
ypserve should run

Additional info:
This appears to have been fixed in future versions of ypserv by simply
ignorign the ECHILD result.

Comment 1 Neil Horman 2004-10-22 18:48:36 UTC
Created attachment 105668 [details]
backport of RHEL3 patch to fix echild death in ypserv

This is a backport of the ypserv patch in RHEL3 to prevent this error

Comment 2 Chris Feist 2004-10-22 22:43:32 UTC
The patched package has been added to the dist-2.1AS-errata-candidate
collection.

The new package name is - ypserv-2.8-9.21.i386.rpm

Comment 3 Neil Horman 2004-10-22 23:45:20 UTC
beautiful.  Thanks!

Comment 4 Neil Horman 2005-03-03 18:08:50 UTC
Since this is checked in, should it be in modified state?

Comment 5 Chris Feist 2005-03-03 18:44:26 UTC
Yes, I didn't assign to myself when I fixed it.  Moving to modified now.

Comment 17 Red Hat Bugzilla 2006-03-21 14:21:45 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0203.html



Note You need to log in before you can comment on or make changes to this bug.