Bug 136861 - The GIMP does not use GtkFileChooser
The GIMP does not use GtkFileChooser
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-10-22 15:04 EDT by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-23 11:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2004-10-22 15:04:03 EDT
Build Identifier: 

The GIMP (or our packages, at least) appears to have its own file selection
dialog, rather than the new GtkFileChooser dialog which is used by the rest of
the desktop.

Reproducible: Always
Steps to Reproduce:
1. run the GIMP
2. select File->Open

Actual Results:  
Ugly file selection dialog appears, which is inconsistent with the rest of the

Expected Results:  
A GtkFileChooser dialog should appear, for consistency with the rest of the desktop

This also affects File->Save As, and no doubt various other places within the

I'm not sure what the politics of this is WRT to getting this change upstream,
however I feel that our packages should consistently be using the new dialog.
Comment 1 Dave Malcolm 2004-10-22 15:06:02 EDT
This was using: gimp-2.0.5-3
Comment 2 Nils Philippsen 2004-10-25 11:09:21 EDT
There are 26 source files where we'd need to change from
GtkFileSelection to GtkFileChooser API. You obviously know better how
much effort this is -- is it worth it considering that we're way past
freeze for FC3 and we'll get this for free with GIMP 2.2?
Comment 3 Dave Malcolm 2004-10-25 11:34:17 EDT
Fair enough - no, I don't see this happening for FC3.

I just wanted to flag it as an issue; sounds like it will be fixed in
the RHEL5/FC4 timeframe.  Thanks.

Comment 4 Nils Philippsen 2004-11-23 11:52:45 EST
gimp-2.2-pre uses the new file chooser

Note You need to log in before you can comment on or make changes to this bug.