Bug 136906 - No possibility to disable multicast from ifcfg-*
No possibility to disable multicast from ifcfg-*
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-22 20:04 EDT by Ulrich Drepper
Modified: 2014-03-16 22:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 16:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add MULTICAST variable handling (472 bytes, patch)
2004-10-22 20:04 EDT, Ulrich Drepper
no flags Details | Diff

  None (edit)
Description Ulrich Drepper 2004-10-22 20:04:04 EDT
Description of problem:
When network interfaces are brought up and they are able to do multicast, this
option is always set.  This might not be desirable in all cases (like mDNS, you
don't want to unnecessarily send out data where there will never be a reply).

Version-Release number of selected component (if applicable):
initscripts-7.68-1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
The attached patch adds handling for a variable called MULTICAST.  I don't know
whether this is in line with guidelines for the init scripts but it works for me.
Comment 1 Ulrich Drepper 2004-10-22 20:04:04 EDT
Created attachment 105680 [details]
Add MULTICAST variable handling
Comment 2 Bill Nottingham 2005-10-03 16:05:28 EDT
At the request of the networking maintainer, support for setting allmulti and
promiscuous mode was taken out from the same location. I'd suspec multicast
would fall under the same category.

Note You need to log in before you can comment on or make changes to this bug.