Bug 136953 - Fedora does not create HomePNA connection
Fedora does not create HomePNA connection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 18:13 EDT by Jan-Petter Vainionpaa
Modified: 2014-03-16 22:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 11:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan-Petter Vainionpaa 2004-10-23 18:13:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20040913 Firefox/0.10

Description of problem:
I Have AMD PCNet 79C978 HomePNA card, and when I first made a fresh
Fedora Core 2 installation from CD ROM images, my network connection
worked fine.

But after updating my installation up to date (installed all updates
available 23.10.2004) network connection stopped working. During boot
and later when I try to say "#service network restart" I get the
message "link is down, check the cable".

I found an older very similar looking problem from bug database (ID
111178), and I assumed that these problems might be related. Therefore
I targetted this problem to initscripts, and I apologize if that is
not the case. 

But It should be mentioned that during the update of my system not
only initscripts-7.53-1 was replaced with initscripts-7.55.1-1, but
also kernel-2.6.5-1 was replaced with kernel-2.6.8-1

I tried networking with both kernel versions, with no success, and I
also tried to reinstall (with --nodeps --oldpackage options) the
original version of initscripts, and tried that with both kernels. But
neither of these procedures helped.

Version-Release number of selected component (if applicable):
initscripts-7.55.1-1

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora Core 2 to a machine with AMD PCNet 79C978 HomePNA
network connection. Connection works fine.
2. Update machine, forexample with yum
3. Try to start network connection
    

Actual Results:  Network connection does not start, instead error
"Link is down, check the cable" is printed.

Expected Results:  Network connection should be established as before.

Additional info:

With the Reproducibility I mean that problem occures every time I try
to use NW and with every combination of initscript and kernel version
I installed and tried on the system, as explained before. 

I did not make a fresh installation every time :)
Comment 1 Jan-Petter Vainionpaa 2004-10-24 04:12:28 EDT
Same problem occures with a new installation of Fedora Core 3 test 3,
AMD PCNet HomePNA adapter is recognized correctly, but network
connection fails. I just get the same notification as with Fedora Core
2, that is "Link is down, check the cable".

I have a dual boot configuration on the machine, and the card works ok
in windows XP.

So far, only new installation of Fedora Core 2 without any updates
worked correctly.
Comment 2 Barry K. Nathan 2004-10-25 02:01:31 EDT
Assuming the card is eth0, try adding either of these lines:

options eth0 homepna=1
options pcnet32 homepna=1

to your /etc/modprobe.conf. (I would then run "depmod -a" and reboot.
Maybe a "depmod -a; /etc/init.d/network restart" or a reboot alone
would suffice, however.) Then see if you still have the problem.


On an unrelated note, in the future please write (for example) "bug
111178", not "ID 111178", for bugs within this Bugzilla database. That
way, Bugzilla can automatically turn it into a clickable link like the
one in the previous sentence. Thanks!
Comment 3 Barry K. Nathan 2004-10-25 02:20:55 EDT
BTW, some more info on why this is happening: Previously, the
connection to use on these cards (HomePNA or Ethernet) had to be
selected at compile time by changing the pcnet32.c source code file.
Recently, the driver was changed so that the type of connection could
be specified using a kernel configuration option (so that, like any
other Linux Ethernet driver, you could change the configuration
without having to edit the source code). Finally, the driver was
improved again, so that you can now choose at module load time rather
than having to recompile the kernel.
Comment 4 Jan-Petter Vainionpaa 2004-10-27 11:36:24 EDT
Hi Barry,

I'm sorry for my answer being late, but I wasn't able to do the test
before today.

Your suggestition worked fine, many thanks for that!! 

I just added the options -line (options eth0 homepna=1) under the
alias definition of eth0 and after updating module dependencies and
booting the machine network worked just fine.

This was clearly not a bug, and I should have looked the documentation
of the driver before making bug report, I apologize of causing extra
work to you all.

br. JP
 

Note You need to log in before you can comment on or make changes to this bug.