Bug 136975 - Thunderbird Save-All shows "Open" file dialog
Summary: Thunderbird Save-All shows "Open" file dialog
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-24 16:47 UTC by Nils O. Selåsdal
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 10:27:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nils O. Selåsdal 2004-10-24 16:47:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Running Thunderbird from rawhide, I noticed right clicking on an
attachment recieved, and choosing "Save-All" brings up a Gtk file
dialog, but the "action" button on that dialog spells "Open".
Somewhat confusing. Should probably bring up the Save dialog
like "Save-As" does.

Version-Release number of selected component (if applicable):
thunderbird-0.8.0-9

How reproducible:
Always

Steps to Reproduce:
1. Recieve a mail with several attacments
2. Right click the bottom where all attacments are shown.
3. Choose Save-All
4. Navigate to where you want it saved, and intuitivly press the "Open"
   button to save..
    

Actual Results:  Wrong "Open" file dialog shown 

Expected Results:  A Save dialog to show.

Additional info:

Comment 1 Steven Lawrance 2005-02-10 18:58:15 UTC
This seems to not be the case in thunderbird-1.0-2. The file dialog's title says
"Save All Attachments." The directory select button says "Select" instead of
"Open", so it seems correct in that respect.

I'm thinking of opening a new bug around Tunderbird's use of the old file
dialogs instead of the new ones, though I'm still searching to see if one
already exists. I mention this because the "Select" button might be different in
the standardized file dialog that all other programs use.


Comment 2 Christopher Aillon 2005-03-31 10:27:35 UTC
Definitely fixed in current versions.


Note You need to log in before you can comment on or make changes to this bug.