Bug 136980 - 4 * missing return statement + local variable not set
Summary: 4 * missing return statement + local variable not set
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iiimf-le-chinput   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-24 17:36 UTC by David Binderman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 0.3-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 11:41:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2004-10-24 17:36:27 UTC
Description of problem:

I just tried to compile package iiimf-le-chinput-0.3-9 from 
Redhat Fedora Core 3 Test 3.

The compiler said

1.

xl_sysphrase.c(271): remark #592: variable "pPhrase" is used before
its value is set

The source code is

    PureSystemPhrase *pPhrase = pPhrase;

pPhrase gets set to it's own uninitialised value. Suggest code rework.

2.

addphrase.c(161): warning #1011: missing return statement at end of
non-void function "ProcessingSystemPhrase"

The source code is

    fclose (fp);
}

Suggest add return statement, since the function returns data type int.

3.

levelphrase.c(143): warning #1011: missing return statement at end of
non-void function "ProcessingSystemPhrase"

Duplicate.

4.

xaux_ext_common.c(347): warning #1011: missing return statement at end
of non-void function "xaux_ext_process_client_message"

Similar.

5.

Converter.c(108): remark #1011: missing return statement at end of
non-void function "modifyEvent"

In this case, suggest mark return type of function as void.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Yu Shao 2004-10-29 11:41:35 UTC
patch made and built, thanks.


Note You need to log in before you can comment on or make changes to this bug.