Bug 136995 - FC3 test3 hangs during installation in SATA HD
FC3 test3 hangs during installation in SATA HD
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-24 20:58 EDT by Alberto Davila
Modified: 2013-07-02 22:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alberto Davila 2004-10-24 20:58:38 EDT
Description of problem:

FC3 test3 hangs trying to install in SATA (VIA) HD


Version-Release number of selected component (if applicable):

FC3 test3 in a Athlon XP 3000+ machine. Video card: sis xabre 64MB. 
SATA HD 120GB. 1GB RAM.

How reproducible:

Try to install in a machine like mine.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

It hangs exactly when anaconda is loading the SATA drives. I tried 
the nofab and nonfab option to start anaconda but it did not work.

Expected results:


Additional info:

That is not the first time I cannnot install Fedora. FC2 also failed 
to recognized other SATA HD during installation.
Comment 1 Dave Jones 2004-10-27 00:32:13 EDT
still repeatable with the RC2 tree ? http://testing.fedora.redhat.com/tree/
Comment 2 Alberto Davila 2004-11-02 07:12:01 EST
I tried the last ISOs available in the tree, and got the following error:

Waiting for X server to start... log located in /tmp/X.log
1...2...3...4...5...
X server started successfully
XIO: fatal IO error 104 (connection reset by peer) on X server ":1.0"
after 0 request (0 known processed) with 0 events remaining ...
Install exited abnormally
Sending termination signals ... done...

My video card is:
‎SiS330 Xabre 2D/3D Accelerator (64 MB)

Bridges and system controllers (VIA):
VT8377 CPU to PCI Bridge
PCI-to-PCI Bridge (AGP 2.0/3.0)
VT8237 PCI-to-ISA Bridge

IDE/ATA controllers:
VT82C586 IDE [Apollo]

SATA controller:
VT8237 SATA150 Controller

Monitor: Samsung SyncMaster 793v

What I should do now ?
Comment 3 Anssi Johansson 2004-11-04 19:36:41 EST
Is this really a SATA issue? The latest error message looks like an X
error message to me. Have you tried installing in text mode? Try
entering "linux text" in the boot prompt. Besides, the option you
should have tried is "nofb", I think options nofab or nonfab do not
exist. Does the install work on regular parallel ATA drives?
Comment 4 Alberto Davila 2004-11-13 14:00:10 EST
No longer sure what problem it is. Will try to install on parallel 
ATA drivers.

I just changed my graphic card to: Nvidia Geforce MX 4000, AGP 8X 
126MB DDR, downloaded the final release of FC3, then tried to install 
with "linux text", and got this:

...
EIP: 0060:[<00c01691>] Not tainted VLI
EFLAGS: 00010202 (2.6.9.-1.667)
EIP is at 0xc01691
...

Code: Bad EIP value
<0>Kernel panic -not syncing: Fatal exception in interrupt

Any ideas on how to solve this ?
Comment 5 Alberto Davila 2005-01-11 06:42:09 EST
After the official release of FC3 I decided to give another try to it 
in another machine (Athlon XP 2600+, 80GB Sata HD)... it apparently 
installs OK, none error message during install, but ... got the 
(first) boot freezing ... I removed the "rhgb quiet" option from the 
boot then it pass the "Red Hat Nash version 4.1.18" step but stops 
later during :

ata1: dev 0 ATA, max UDMA/133, 156301488 sectors: lba48

Could you kindly let me know how (what commands) I could obtain logs 
to provide you with them ? I searched the web and looks like the big 
problem is the lack of SATA support by Fedora... I was hoping FC3 
could work better than FC2 (it also does not support SATA) ... 
Mandrake 10.0 (or higher) install nicely in my SATA HD. In case you 
already added support for SATA, where (and how) I could use it ?
Comment 6 David Timms 2005-05-11 07:23:22 EDT
FC3 install on a Via EPIA miniATX motherboard with built in VIA SATA controller
also hangs during start up with "loading sata_via driver".

A workaround is shown in
https://www.redhat.com/archives/fedora-list/2005-February/msg02259.html
ie: make boot line: linux acpi=off
which works on this motherboard.

Looks like FC4test2 has better support.
Comment 7 Dave Jones 2005-07-15 16:28:26 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Dave Jones 2005-10-02 21:03:50 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.