Bug 137005 - nash "pivot_root" fails
Summary: nash "pivot_root" fails
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-25 03:42 UTC by james
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 12:39:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description james 2004-10-25 03:42:53 UTC
Description of problem:
Use of "pivot_root" with Red Hat nash version 4.1.15 fails when using 
initramfs and /init.  Only "switchroot" can be used in the boot 
process.

Version-Release number of selected component (if applicable):
mkinitrd-4.1.15-1

How reproducible:
always

Steps to Reproduce:
1. write an initrd using "pivot_root" instead of "switchroot"
2. reboot
3.
  
Actual results:
eventually, kernel panic

Expected results:


Additional info:

Comment 1 Jeremy Katz 2004-10-25 12:39:59 UTC
This is due to how initramfs is implemented within the kernel.

If you're using an initramfs, you must use switchroot and not pivot_root.

Comment 2 james 2004-10-27 23:05:44 UTC
> If you're using an initramfs, you must use switchroot and not
pivot_root.

Then this is a "bug" in the nash manpage.  Simple comments to that
effect should be added to "switchroot" and "pivot_root" on the nash
manpage.


Note You need to log in before you can comment on or make changes to this bug.