Bug 1370095 - PCS version in F24 conflicts with the one in F23: version upgrade failed
Summary: PCS version in F24 conflicts with the one in F23: version upgrade failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcs
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-25 10:06 UTC by Marco Peccianti
Modified: 2016-10-28 19:51 UTC (History)
6 users (show)

Fixed In Version: pcs-0.9.154-2.fc24 pcs-0.9.154-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-25 04:27:33 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1299835 0 unspecified CLOSED pcsd fails to start due to module loading errors 2021-02-22 00:41:40 UTC

Internal Links: 1299835

Description Marco Peccianti 2016-08-25 10:06:07 UTC
Description of problem:
F23 seems to have files conflicting in PCS for F24, and the system-upgrade command complains about this.


Version-Release number of selected component (if applicable):
pcs-0.9.150-1.fc24.x86_64
pcs-0.9.149-2.fc23.x86_64

How reproducible:
upgrading version procedure

Steps to Reproduce:
1. dnf system-upgrade download --refresh --releasever=24
2. dnf system-upgrade download --refresh --releasever=24 --allowerasing
3. dnf system-upgrade download --refresh --releasever=24 --allowerasing --best

Actual results:

every try ends in:
Transaction check error:
  il file /usr/lib/pcsd/vendor/bundle/ruby/gems dell'installazione di pcs-0.9.150-1.fc24.x86_64 entra in conflitto con il file del pacchetto pcs-0.9.149-2.fc23.x86_64
  il file /usr/lib/pcsd/vendor/bundle/ruby/extensions dell'installazione di pcs-0.9.150-1.fc24.x86_64 entra in conflitto con il file del pacchetto pcs-0.9.149-2.fc23.x86_64
  il file /usr/lib/pcsd/vendor/bundle/ruby/specifications dell'installazione di pcs-0.9.150-1.fc24.x86_64 entra in conflitto con il file del pacchetto pcs-0.9.149-2.fc23.x86_64

(italian version: file X from package Y conflicts with the one in package Z)

Note: Fedora previously upgraded from F22

Comment 1 Tomas Jelinek 2016-09-22 15:58:36 UTC
pcs-0.9.150-1.fc24 has been built in a way that some directories were replaced by symlinks to directories, hence the upgrade problems. pcs-0.9.154-1.fc24 and pcs-0.9.154-1.fc25 return to the same directory tree as pcs-0.9.149-2.fc23 has to make the upgrade seamless.

However that means upgrading from pcs-0.9.150-1.fc24 will fail with the same error as pcs-0.9.150-1.fc24 is broken (the symlinks were a quickfix to other issue). Workaround:
dnf remove pcs
dnf install pcs
systemctl enable pcsd
systemctl start pcsd

Comment 2 Fedora Update System 2016-09-24 00:54:03 UTC
pcs-0.9.154-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-61deaec93a

Comment 3 Fedora Update System 2016-09-24 01:51:40 UTC
pcs-0.9.154-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b0d3ba086

Comment 4 Fedora Update System 2016-10-10 17:47:54 UTC
pcs-0.9.154-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2016-10-10 21:50:45 UTC
pcs-0.9.154-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 David Juran 2016-10-11 10:48:03 UTC
Something is still not working, the update is failing on an F24:

Error: Transaction check error:
  file /usr/lib/pcsd/vendor/bundle/ruby/extensions from install of pcs-0.9.154-1.fc24.x86_64 conflicts with file from package pcs-0.9.150-1.fc24.x86_64
  file /usr/lib/pcsd/vendor/bundle/ruby/gems from install of pcs-0.9.154-1.fc24.x86_64 conflicts with file from package pcs-0.9.150-1.fc24.x86_64
  file /usr/lib/pcsd/vendor/bundle/ruby/specifications from install of pcs-0.9.154-1.fc24.x86_64 conflicts with file from package pcs-0.9.150-1.fc24.x86_64

Comment 7 Tomas Jelinek 2016-10-11 15:29:39 UTC
I was not able to figure out how to fix this, see comment 1 for details.

Comment 8 Marco Peccianti 2016-10-14 12:43:08 UTC
I updated my cluster, one node with uninstall&&reinstall pcs, one node with the standard upgrade procedure.

I can confirm:

- F23->F24 transition now is working correctly with
     "dnf system-upgrade download --refresh --releasever=24"

- bug in comment #6

Comment 9 Marco Peccianti 2016-10-14 12:48:04 UTC
I can also confirm that the trick

- dnf uninstall pcs
- dnf install pcs

works without problems

Comment 10 David Juran 2016-10-17 15:32:21 UTC
Sorry, missed the comment in #1. So it seems it's the ancient issue from https://bugzilla.redhat.com/show_bug.cgi?id=447156

See that Bz for some hints on how to work around the problem

Comment 11 Tomas Jelinek 2016-10-18 13:30:16 UTC
Thanks David. I updated the spec file as described in https://fedoraproject.org/wiki/Packaging:Directory_Replacement. Updating the pcs package works for me with the new build.

Comment 12 Fedora Update System 2016-10-19 18:55:35 UTC
pcs-0.9.154-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-06f957ad67

Comment 13 Fedora Update System 2016-10-19 19:56:09 UTC
pcs-0.9.154-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e17fcc5e63

Comment 14 Fedora Update System 2016-10-25 04:27:33 UTC
pcs-0.9.154-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-10-28 19:51:15 UTC
pcs-0.9.154-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.