Bug 137029 - Freeze with Fedora kernels
Freeze with Fedora kernels
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 08:02 EDT by Thierry Chantry
Modified: 2015-01-04 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 13:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thierry Chantry 2004-10-25 08:02:35 EDT
Description of problem:
Hi,

Few moths ago,I have ported an application, that contains 
executables, shared libraries and modules, from Linux Redhat 7.3 
(kernel 2.4.18-3) to Fedora Core 2 (kernel 2.6.5-1.358).
This application works perfectly on RH7.3.

I've done the port first on Fedora 1.9 (kernel 2.6.1-1.65), the Core 
2 was not released. The port was a success, I didn't see any problem.
When the Core 2 was released (kernel 2.6.5-1.358), I have recompiled 
everything on that version. This time, I had a problem: a freeze 
occured, after a particular sequence with my application.

Everytime the freeze occured, it seems that one of my module is doing 
a copy_from_user.
I was very suprised, this module didn't change a lot during the port, 
and it has been used for a long time, without any problem, on RH 7.3. 
This module doesn't work with the hardware, it implements a 
synchronous IPC (message passing). It synchronizes processes and copy 
data from the user to the kernel (or from kernel to user) spaces.

What is really strange, is that when I boot an officicial kernel 
release (I've tested with 2.6.5, 2.6.6 and 2.6.7) it works perfectly. 
However, whith the Fedora kernel releases (tested with 2.6.5-1.358 
and 2.6.6-1.427) the freeze occured.

I'm using the 2.6.7 kernel without any problem but I will use the 
Fedora core 3 as soons as it is available. I'm afraid of encountering 
the same problem with the kernel that will be provided whith this 
distribution. This is why, I'm posting this message.

Questions:
1- Is there a release note that gives differences between the Fedora 
kernel and the corresponding official kernels version (I mean 
diffrences between the 2.6.5-1.358 and the 2.6.5, for exemple) ?
2- I didn't find any post that talk about this kind of kernel freeze 
on the Fedora core 2. Have you got any suggestions ?

Thank you in advance for your help,
Regards
Thierry.

Version-Release number of selected component (if applicable):
kernel 2.6.5-1.358

How reproducible:
Every time

Steps to Reproduce:
1.With my application
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Warren Togami 2004-10-25 08:17:57 EDT
Be advised that 358 is very old news, and no further work will be done
on any kernel even remotely near it.  You may want to retest your
application with the current 640 kernel that will be in FC3's release,
and similar to the RHEL4 kernel.
Comment 2 Thierry Chantry 2004-10-26 05:55:50 EDT
Hi,
Ok, I will test with the 640 kernel, I'll post a conclusion later.
However, could you please answer to my first question:
>1- Is there a release note that gives differences between the Fedora 
>kernel and the corresponding official kernels version (I mean 
>diffrences between the 2.6.5-1.358 and the 2.6.5, for exemple) ?
I understand that you cannot support old product. The goal of my post 
is more to figure out how deep are the changes that you apply to the
official kernel.

Regards.
Thierry
Comment 3 Warren Togami 2004-10-26 05:58:14 EDT
The changes are very minor, because whenever possible we try to
integrate changes into the upstream kernel in order to make it less of
a long term maintenance burden for everyone.  To be honest, I feel
your question is unfair because the source is available.  You can see
for yourself.
Comment 4 Thierry Chantry 2004-10-28 12:35:48 EDT
Hi,
I have downloaded the kernel-2.6.9-1.643.src.rpm ( I didn't find the
kernel-source-2.6.9-1.643.rpm).
To make my tests, I need to rebuild the kernel.
So, is there an easy way to build kernel-source-2.6.9-1.643.rpm from 
the kernel-2.6.9-1.643.src.rpm package?

>a long term maintenance burden for everyone.  To be honest, I feel
>your question is unfair because the source is available.  You can see
>for yourself.
Sorry but I don't think that my question is unfair (as you said). It 
is pretty difficult to compare to kernel versions (even with sources 
and even if there are close). The kernel source tree contains many 
sub-directories and tons of files... I was only looking for a file 
that gives changes that you apply in the kernel. I'll not complain if 
such kind of file doesn't exit.
Any way, I trust you when you say that changes are minor. But, with 
this information, once again, I don't figure out why I had a freeze 
whith the 2.6.5-1.358 and not whith the 2.6.5. I don't want that you 
loose your time with old kernel versions. So, I'll will try the 2.6.9-
1.643 and pray to never see again my problem with it and the next 
fedora kernel versions.

Regards,
Thierry
Comment 5 Warren Togami 2004-10-28 13:26:32 EDT
1) kernel-sourcecode is NO LONGER DISTRIBUTED because it is LESS
USEFUL than the .src.rpm.  In the .src.rpm you can directly look at
the patches before they are applied to the vanilla source.
2) Please learn how to use diff.
3) Is it the kernel (the entire system) or your application that freezes?

Please test both 2.6.9 vanilla and 2.6.9-1.643.
Comment 6 Thierry Chantry 2004-10-29 07:52:19 EDT
1- I'm suprised that you'll no longer provide the kernel-source 
package. How people will be able to customize the kernel ?
2- With my .src.rpm package, what is the easiest way to get the 
complete source code of the 2.6.9-1.643 kernel (I mean where any 
necessary patches are applied and so on...: the equivalent of the 
kernel-source package) . As I told you in my previous post, I need to 
customise the kernel to make my application working correctly.
3- To answer to your third question, the entire system is frozen. 
Keyboard and mouse don't work. I can ping that machine any more.
4- I'll start my test this afternoon on the 2.6.9 vanilla. As soon as 
I will be able to customise the 2.6.9-1.643, I will test it.
Comment 7 Thierry Chantry 2004-11-04 09:14:58 EST
The 2.6.9 vanilla works perfectly.
Comment 8 Dave Jones 2004-11-20 02:05:41 EST
is this still causing problems with todays errata kernel ?
can you post the source of the problematic module ?
Comment 9 Thierry Chantry 2004-12-03 05:05:51 EST
As I didn't reproduce this problem with the Fedora Core (kernel 2.6.9-
1.667), we can close this bug...
Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.