Bug 137049 - cdrecord-2.01.1-0.FC2.1 hangs on my Cyberdrive CW088D
cdrecord-2.01.1-0.FC2.1 hangs on my Cyberdrive CW088D
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-25 11:47 EDT by Matthias Bachert
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 10:16:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (16.95 KB, text/plain)
2004-10-25 11:48 EDT, Matthias Bachert
no flags Details

  None (edit)
Description Matthias Bachert 2004-10-25 11:47:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7.3)
Gecko/20040922

Description of problem:
If I use cdrecord with my Cybedrive CW088D it hangs instead of
executing command (e.g. blank CD-RW).

Version-Release number of selected component (if applicable):
cdrecord-2.01.1-0.FC2.1

How reproducible:
Always

Steps to Reproduce:
1. Calling "cdrecord blank=fast" on my Cyberdrive CW088D

Actual Results:  cdrecord hangs.

Expected Results:  cdrecord commands should be executed

Additional info: previous Versions of cdrecord work as expected
Comment 1 Matthias Bachert 2004-10-25 11:48:46 EDT
Created attachment 105729 [details]
strace output
Comment 2 Harald Hoyer 2004-10-25 11:51:37 EDT
which kernel do you have?
Comment 3 Matthias Bachert 2004-10-26 02:39:42 EDT
original fedora kernel version 2.6.7-?
Comment 4 Matthias Bachert 2004-10-26 02:40:31 EDT
also tried with fedora's 2.6.8-?
Comment 5 Harald Hoyer 2004-10-26 08:41:58 EDT
try it with the original fedora core kernel as root.
Comment 6 Matthias Bachert 2004-10-26 12:10:02 EDT
it takes time but it works.

Here is the output:
------------------------
[root@matthias root]# cdrecord blank=fast
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004
Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in
this version.
scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c       
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'CyberDrv'
Identifikation : 'CW088D CD-R/RW  '
Revision       : '120F'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-2 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R
resid: 64512
cdrecord: Success. read buffer: scsi sendcmd: no error
CDB:  3C 00 00 00 00 00 00 FC 00 00
status: 0x4 (CONDITION MET/GOOD)
resid: 64508
cmd finished after 40.381s timeout 40s
Speed set to 2824 KB/s
Starting to write CD/DVD at speed  16.0 in real BLANK mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Comment 7 Harald Hoyer 2004-10-27 04:28:17 EDT
BUG or not?
Comment 8 Matthias Bachert 2004-10-27 06:50:55 EDT
who decides this?
Comment 9 Harald Hoyer 2004-10-27 07:58:28 EDT
if it works, where is the bug?
if you mean, that with the new kernel, it does not work anymore, 
then this is a duplicate of bug #130576
Comment 10 Matthias Bachert 2004-10-28 10:32:38 EDT
it worked with previous versions of cdrecord so it must be a bug in
cdrecord too.
Comment 11 Harald Hoyer 2004-10-28 11:21:19 EDT
maybe it lasts long? I don't see any bad things happen in your strace...
Comment 12 Matthias Bachert 2004-10-28 11:31:08 EDT
had it running one whole night and it just hung.
Comment 13 Harald Hoyer 2004-11-01 04:02:11 EST
ok, that is a bug, then
Comment 14 Matthew Miller 2005-04-26 12:35:14 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 15 Harald Hoyer 2005-09-16 10:16:02 EDT
sorry, I can't fix this, and I hope it works with recent kernels and cdrecord.
Comment 16 Andre Robatino 2006-08-21 06:34:38 EDT
  The problem still exists with FC5, I've opened bug #203248.  Burning works
partially using cdrdao instead of cdrecord - it's possible to burn a blanked
disc, but not to blank a disc.

Note You need to log in before you can comment on or make changes to this bug.