Bug 137067 - nbd loses request structures, eventually hangs system
Summary: nbd loses request structures, eventually hangs system
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
high
Target Milestone: ---
: ---
Assignee: Kiersten (Kerri) Anderson
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-25 17:13 UTC by Paul Clements
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 17:58:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nbd patch (2.41 KB, patch)
2004-10-25 17:16 UTC, Paul Clements
no flags Details | Diff

Description Paul Clements 2004-10-25 17:13:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
A bug in the nbd driver causes struct requests to be lost, which over
time will cause the system to livelock (kernel debugger trace shows
CPU spinning trying to get a request, which nbd never releases). The
patch to fix this problem is now in mainline, and is attached to this
bug report.

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.528.2.10

How reproducible:
Always

Steps to Reproduce:
1. perform I/O over nbd while periodically breaking the nbd connection
and re-establishing it

Actual Results:  system livelocks

Expected Results:  system should continue working normally

Additional info:

Comment 1 Paul Clements 2004-10-25 17:16:28 UTC
Created attachment 105733 [details]
nbd patch

Comment 2 Bill Nottingham 2004-10-26 16:19:29 UTC
At what point was this patch added to mainline?

Comment 3 Paul Clements 2004-10-26 16:53:14 UTC
~2.6.8 -- I don't have a pristine 2.6.8 sitting in front of me, but it
was around that time, may have been slightly before or after

Comment 7 Kiersten (Kerri) Anderson 2004-10-28 22:07:23 UTC
The patch has already been applied to the RHEL4 B2 kernel when we
updated to the 2.6.9 base, so will be in the B2 release kernel when
available.

Comment 8 Jay Turner 2005-01-13 17:58:21 UTC
Closing out.  Please reopen if the problem is still present with recent code.


Note You need to log in before you can comment on or make changes to this bug.