Bug 137083 - (IT_50325) redhat-config-samba cannot add users or change passwords
redhat-config-samba cannot add users or change passwords
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-samba (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
: 159118 (view as bug list)
Depends On:
Blocks: 156320
  Show dependency treegraph
 
Reported: 2004-10-25 14:15 EDT by David Lehman
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2005-321
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 16:20:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2004-10-25 14:15:29 EDT
Description of problem:
r-c-samba tries to call smbpasswd with '-s' to supply password on
stdin, which smbpasswd stopped supporting around samba-3.0.6.

Version-Release number of selected component (if applicable):
redhat-config-samba-1.0.16-2

How reproducible:
always

Steps to Reproduce:
1. try to add a samba account for an existing user via r-c-samba
2.
3.
  
Actual results:
no error message is displayed, but if you started r-c-samba from a
terminal you will see smbpasswd display a usage message and fail to
add the user

Expected results:
user added successfully

Additional info:
Comment 1 Vince Worthington 2004-10-27 12:56:16 EDT
Have multiple customers with support requests open on this (4, at the
moment)
Comment 2 Nils Philippsen 2004-10-28 04:18:49 EDT
This bug is solved in current system-config-date packages. I intend to backport
the patch and build an erratum for RHEL3 U5.
Comment 3 Nils Philippsen 2004-11-02 02:51:51 EST
Argh. Make that system-config-samba of course.
Comment 4 Nils Philippsen 2004-11-02 11:28:48 EST
This is the same as bug #132084.
Comment 7 John Wiencek 2004-12-13 14:00:21 EST
I too have seen this problem.  When adding a user via this GUI,
nothing is added to the list but if you try to add same user again, an
error indicates the user is already on the list (even though nothing
is displayed).  Samba is not functioning properly due to the lack of a
defined password.  This bug looks like bug 90514
Comment 9 Florian La Roche 2005-05-30 02:27:11 EDT
*** Bug 159118 has been marked as a duplicate of this bug. ***
Comment 16 Red Hat Bugzilla 2005-09-28 16:20:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-321.html

Note You need to log in before you can comment on or make changes to this bug.