Bug 137083 (IT_50325) - redhat-config-samba cannot add users or change passwords
Summary: redhat-config-samba cannot add users or change passwords
Status: CLOSED ERRATA
Alias: IT_50325
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-samba   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
: 159118 (view as bug list)
Depends On:
Blocks: 156320
TreeView+ depends on / blocked
 
Reported: 2004-10-25 18:15 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version: RHBA-2005-321
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 20:20:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:321 qe-ready SHIPPED_LIVE redhat-config-samba bug fix update 2005-09-28 04:00:00 UTC

Description David Lehman 2004-10-25 18:15:29 UTC
Description of problem:
r-c-samba tries to call smbpasswd with '-s' to supply password on
stdin, which smbpasswd stopped supporting around samba-3.0.6.

Version-Release number of selected component (if applicable):
redhat-config-samba-1.0.16-2

How reproducible:
always

Steps to Reproduce:
1. try to add a samba account for an existing user via r-c-samba
2.
3.
  
Actual results:
no error message is displayed, but if you started r-c-samba from a
terminal you will see smbpasswd display a usage message and fail to
add the user

Expected results:
user added successfully

Additional info:

Comment 1 Vince Worthington 2004-10-27 16:56:16 UTC
Have multiple customers with support requests open on this (4, at the
moment)

Comment 2 Nils Philippsen 2004-10-28 08:18:49 UTC
This bug is solved in current system-config-date packages. I intend to backport
the patch and build an erratum for RHEL3 U5.

Comment 3 Nils Philippsen 2004-11-02 07:51:51 UTC
Argh. Make that system-config-samba of course.

Comment 4 Nils Philippsen 2004-11-02 16:28:48 UTC
This is the same as bug #132084.

Comment 7 John Wiencek 2004-12-13 19:00:21 UTC
I too have seen this problem.  When adding a user via this GUI,
nothing is added to the list but if you try to add same user again, an
error indicates the user is already on the list (even though nothing
is displayed).  Samba is not functioning properly due to the lack of a
defined password.  This bug looks like bug 90514

Comment 9 Florian La Roche 2005-05-30 06:27:11 UTC
*** Bug 159118 has been marked as a duplicate of this bug. ***

Comment 16 Red Hat Bugzilla 2005-09-28 20:20:06 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-321.html



Note You need to log in before you can comment on or make changes to this bug.