Bug 1370858 - NetworkManager doesn't prompt for password
Summary: NetworkManager doesn't prompt for password
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-openconnect
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-08-27 14:29 UTC by Alex
Modified: 2016-08-27 22:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-27 22:43:29 UTC


Attachments (Terms of Use)

Description Alex 2016-08-27 14:29:10 UTC
Description of problem:
I configured openconnect VPN and wanted to use NetworkManager to connecto the corporate network. But every time I try to turn on the VPN and fails immediately. I found in the log of NetworkManager that it can't find application to prompt for password.

From the log:
NetworkManager[1091]: <error> [1472306950.6997] vpn-connection[0x557864ac61d0,8086690f-f62e-47d7-a316-724782cb035d,"VPN",0]: Failed to request VPN secrets #3: No agents were available for this request.


Version-Release number of selected component (if applicable):
NetworkManager-config-connectivity-fedora-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-openvpn-1.2.4-2.fc25.x86_64
NetworkManager-vpnc-1.2.2-1.fc25.x86_64
NetworkManager-glib-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-wwan-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-openconnect-gnome-1.2.3-0.20160606git5009f9.fc25.x86_64
NetworkManager-openconnect-1.2.3-0.20160606git5009f9.fc25.x86_64
NetworkManager-libnm-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-vpnc-gnome-1.2.2-1.fc25.x86_64
NetworkManager-team-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-bluetooth-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-wifi-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-pptp-1.2.2-1.fc25.x86_64
NetworkManager-openvpn-gnome-1.2.4-2.fc25.x86_64
NetworkManager-adsl-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-1.4.0-0.5.git20160621.072358da.fc25.x86_64
NetworkManager-pptp-gnome-1.2.2-1.fc25.x86_64
gnome-keyring-3.20.0-1.fc25.x86_64
gnome-keyring-pam-3.20.0-1.fc25.x86_64

How reproducible:
Create openconnect VPN connection in Fedora 25 and try to connect. I used VPN connection with encrypted cert and secure token authentication. So before upgrading to Fedora 25 NetworkManager would ask for cert password and secure token password. Now it just silently fails to connect with only indication in the log.


Steps to Reproduce:
1. Configure openconnect VPN
2. Try to turn on the VPN

Actual results:
Connection setup silently fails without asking password.

Expected results:
NetworkManager should ask for password for certificate and for secure token.

Additional info:
I suspect that this may happen because Fedora 25 has gnome-3.21.* for most of the packages and gnome-keyring is 3.20.0

Comment 1 Thomas Haller 2016-08-27 14:49:22 UTC
to request a password/secret, NetworkManager calls out to a "secret-agent". That is a program that obtains the password somehow, for example by asking the user or looking into the keyring.

Such secret agents are for example nmcli, nmtui, plasma-nm, nm-applet, gnome-shell.

To handle secrets for VPN (and especially for openconnect which is more complicated) the secret agent also needs help from the VPN plugin. Certainly nm-applet is able to do all of that, not sure about the others.


Can you first try with having nm-applet running?


(I see, you have the relevant plugin installed: NetworkManager-openconnect-gnome)

Comment 2 Alex 2016-08-27 22:43:29 UTC
With latest update new NetworkManager came in fc25 and now everything works as expected. Thank you!


Note You need to log in before you can comment on or make changes to this bug.