Bug 137107 - vgcreate: autobackup always set to no
Summary: vgcreate: autobackup always set to no
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-lvm   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jim Parsons
QA Contact: Jim Parsons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-25 19:59 UTC by Derek Anderson
Modified: 2009-04-16 23:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 15:24:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Derek Anderson 2004-10-25 19:59:39 UTC
Description of problem:
It looks like the autobackup flag is always set to "n" whether the
checkbox on the create VG dialog is checked or not.  I added a debug
print in CommandHandler.py before the vgcreate command (~line 95) to
print out the value of autobackup_arg before the command is executed.
 Then created two volumes: one with the autobackup box checked and one
without.  Both times the autobackup_arg was 'n'.

Point 2: The man page for vgcreate states that autobackup is on by
default.  So once this is working the box should be checked by default
to be consistent with default command line behavior.

Another strange note about this flag (and this is LVM-specific, not
the GUI) is that whether you run with '-A y' or '-A n' the VG backup
text file gets updated in /etc/lvm/backup/VGname when you make a
change to the VG.  If I understand this correctly LVM is running
autobackup=y even when you specify you don't want it.

Version-Release number of selected component (if applicable):
system-config-lvm-0.9.1-2.5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jim Parsons 2004-10-29 21:52:00 UTC
Fixed in 0.9.4-1.0 by removing checkbox. LVM2 pkg maintainer wishes
that  the option to NOT backup metadata is never presented to the user.

Comment 2 Derek Anderson 2004-11-04 15:24:21 UTC
Verified in system-config-lvm-0.9.6-1.0 that:
- On new VG creation the Autobackup checkbox is not available
- For each VG the backup is in fact on.  Check /etc/lvm/backup/VGname.


Note You need to log in before you can comment on or make changes to this bug.